aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.in
diff options
context:
space:
mode:
authorMarlon James <marlon.james@gmail.com>2021-03-03 10:33:56 -0800
committertgingold <tgingold@users.noreply.github.com>2021-03-04 07:49:28 +0100
commit783cbac7ba4c14aa7e27f28755dccd7e4ee4d54e (patch)
tree929ab92aac895ec39b5e7780e1fe8cea3edf3be1 /Makefile.in
parenta03aedddf650f923b06ebacb441a713930cd63e1 (diff)
downloadghdl-783cbac7ba4c14aa7e27f28755dccd7e4ee4d54e.tar.gz
ghdl-783cbac7ba4c14aa7e27f28755dccd7e4ee4d54e.tar.bz2
ghdl-783cbac7ba4c14aa7e27f28755dccd7e4ee4d54e.zip
VHPI: add initial minimal implementation
Minimal implementation of VHPI provides library loading and error support. Calling most vhpi_* functions will raise a VHPI error condition. Incorporates VHPI thunks into libghdlvpi for linking.
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in15
1 files changed, 11 insertions, 4 deletions
diff --git a/Makefile.in b/Makefile.in
index a1bc2a718..a8a1ae68f 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -513,22 +513,29 @@ vpi_thunk.o: $(GRTSRCDIR)/vpi_thunk.c $(GRTSRCDIR)/vpi_thunk.h
# Do not use OPT_FLAGS (do not enable coverage)
$(CC) -c -o $@ $< $(PIC_FLAGS) -O $(WARN_CFLAGS)
-lib/libghdlvpi$(SOEXT): vpi_thunk.o
- $(CC) -o $@ $< -shared $(SHLIB_FLAGS)
+vhpi_thunk.o: $(GRTSRCDIR)/vhpi_thunk.c $(GRTSRCDIR)/vhpi_thunk.h
+# Do not use OPT_FLAGS (do not enable coverage)
+ $(CC) -c -o $@ $< $(PIC_FLAGS) -O $(WARN_CFLAGS)
+
+lib/libghdlvpi$(SOEXT): vpi_thunk.o vhpi_thunk.o
+ $(CC) -o $@ $^ -shared $(SHLIB_FLAGS)
all.vpi: lib/libghdlvpi$(SOEXT)
install.vpi: all.vpi install.dirs
$(INSTALL_PROGRAM) -p lib/libghdlvpi$(SOEXT) $(DESTDIR)$(libdir)/
$(INSTALL_DATA) -p $(GRTSRCDIR)/vpi_user.h $(DESTDIR)$(incdir)/
+ $(INSTALL_DATA) -p $(GRTSRCDIR)/vhpi_user.h $(DESTDIR)$(incdir)/
uninstall.vpi:
$(RM) -f $(DESTDIR)$(libdir)/libghdlvpi$(SOEXT)
$(RM) -f $(DESTDIR)$(incdir)/vpi_user.h
+ $(RM) -f $(DESTDIR)$(incdir)/vhpi_user.h
install.vpi.local: all.vpi
$(MKDIR) -p include lib
$(INSTALL_DATA) -p $(GRTSRCDIR)/vpi_user.h include/
+ $(INSTALL_DATA) -p $(GRTSRCDIR)/vhpi_user.h include/
################ Libraries ###############################################
@@ -602,9 +609,9 @@ distclean: clean
clean-c: force
$(RM) -f memsegs_c.o chkstk.o jumps.o times.o
$(RM) -f grt-cstdio.o grt-cgnatrts.o grt-modules.o
- $(RM) -f grt-cvpi.o grt-cdynload.o
+ $(RM) -f grt-cvpi.o grt-cvhpi.o grt-cdynload.o
$(RM) -f fstapi.o fastlz.o lz4.o
- $(RM) -f pic/times.o pic/grt-cvpi.o pic/jumps.o
+ $(RM) -f pic/times.o pic/grt-cvpi.o pic/grt-cvhpi.o pic/jumps.o
$(RM) -f pic/grt-cstdio.o pic/grt-cgnatrts.o pic/grt-modules.o
$(RM) -f pic/grt-cdynload.o