aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.in
diff options
context:
space:
mode:
authorXiretza <xiretza@xiretza.xyz>2021-05-09 16:36:17 +0200
committertgingold <tgingold@users.noreply.github.com>2021-05-10 07:56:17 +0200
commit8402fd01aea378db2541ccd56895f18c3c7f8bab (patch)
tree1a9dd9b99f315e9679840e52c69afcfbdabfc70e /Makefile.in
parent066242de5014013330c4dad7ca8971d8f667a966 (diff)
downloadghdl-8402fd01aea378db2541ccd56895f18c3c7f8bab.tar.gz
ghdl-8402fd01aea378db2541ccd56895f18c3c7f8bab.tar.bz2
ghdl-8402fd01aea378db2541ccd56895f18c3c7f8bab.zip
Makefile.in: pass Ada warning options to GRT
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in16
1 files changed, 9 insertions, 7 deletions
diff --git a/Makefile.in b/Makefile.in
index bdd09dcc1..c11375dc2 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -80,9 +80,16 @@ ifeq "$(build_mode)" "coverage"
COVERAGE_FLAGS+=-fprofile-arcs -ftest-coverage
endif
-GNATFLAGS=-gnat12 -gnaty3befhkmr -gnatwa -gnatwC -gnatf $(OPT_FLAGS) $(COVERAGE_FLAGS) $(ADA_FLAGS)
+# Warnings as errors. Comment this line if a warning looks not valid.
+ifeq "$(enable_werror)" "true"
+WARN_ADAFLAGS+=-gnatwe
+endif
+
+WARN_ADAFLAGS+=-gnatwa -gnatwC -gnatf
+
+GNATFLAGS=-gnat12 -gnaty3befhkmr $(OPT_FLAGS) $(COVERAGE_FLAGS) $(WARN_ADAFLAGS) $(ADA_FLAGS)
GRT_FLAGS=$(OPT_FLAGS) $(COVERAGE_FLAGS)
-GRT_ADAFLAGS:=$(filter-out -gnata,$(ADA_FLAGS))
+GRT_ADAFLAGS:=$(WARN_ADAFLAGS) -gnatw.X $(filter-out -gnata,$(ADA_FLAGS))
ifeq "$(default_pic)" "true"
GRT_FLAGS+=$(PIC_FLAGS)
@@ -92,11 +99,6 @@ WARN_CFLAGS=-Wall
GNAT_BARGS=-bargs -E
-# Warnings as errors. Comment this line if a warning looks not valid.
-ifeq "$(enable_werror)" "true"
-GNATFLAGS+=-gnatwe
-endif
-
target=$(build)
#target=i686-pc-linux-gnu
#target=x86_64-pc-linux-gnu