aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.in
diff options
context:
space:
mode:
authorTristan Gingold <tgingold@free.fr>2023-03-17 08:02:02 +0100
committerTristan Gingold <tgingold@free.fr>2023-03-17 08:02:02 +0100
commitdb9d2b8196cb642eb7b3a5ee34ed7f317848ff55 (patch)
tree61fb639835476ba9ed6ac490d57065c4d1339c57 /Makefile.in
parentd6ccf3815f88ba0b51a8efa6b421dceecff9c43b (diff)
downloadghdl-db9d2b8196cb642eb7b3a5ee34ed7f317848ff55.tar.gz
ghdl-db9d2b8196cb642eb7b3a5ee34ed7f317848ff55.tar.bz2
ghdl-db9d2b8196cb642eb7b3a5ee34ed7f317848ff55.zip
standalone wheels: put date in development versions
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.in b/Makefile.in
index 34382f004..a0a949ff3 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -667,11 +667,14 @@ uninstall.vhdllib:
####################### pyGHDL standalone ################################
setup-standalone.py: $(srcdir)/setup-standalone.in
+# Replace #@__init__ with the variables from __init__.py
+ case "$(ghdl_version)" in *dev*) version="$(ghdl_version).$$(date +%Y%m%d.%H%M)";; *) version="$(ghdl_version)";; esac; \
( \
sed -n -e '1,/^#@__init__/p' < $<; \
sed -n -e '/__author__/,/^$$/p' < $(srcdir)/pyGHDL/__init__.py; \
echo 'srcdir = "$(srcdir)"' ; \
echo 'soext = "$(SOEXT)"'; \
+ echo __version__ = \"$$version\"; \
sed -n -e '/^#@__init__/,$$p' < $< ; \
) > $@