aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.in
diff options
context:
space:
mode:
authorumarcor <unai.martinezcorral@ehu.eus>2021-04-23 00:57:09 +0200
committertgingold <tgingold@users.noreply.github.com>2021-04-23 05:34:09 +0200
commitdc2542b1faef1817d7166458fd51dd2c001f45af (patch)
tree35b68d6d980e4a7ed033ae00f9079cac15487261 /Makefile.in
parentf80af477cdc76a6635eec16ac0f53fad80edde14 (diff)
downloadghdl-dc2542b1faef1817d7166458fd51dd2c001f45af.tar.gz
ghdl-dc2542b1faef1817d7166458fd51dd2c001f45af.tar.bz2
ghdl-dc2542b1faef1817d7166458fd51dd2c001f45af.zip
Makefile: add and use all.ghw, install.ghw and uninstall.ghw targets
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in20
1 files changed, 15 insertions, 5 deletions
diff --git a/Makefile.in b/Makefile.in
index fc86eb2b5..378241e4e 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -124,15 +124,15 @@ LIBVHDL_FLAGS_TO_PASS=\
# Object files from grt for the synthesis.
GRT_SYNTH_OBJS=grt-cstdio.o
-all: Makefile all.$(backend) all.libghdl
+all: Makefile all.$(backend) all.libghdl all.ghw
-install: install.$(backend) install.vhdllib install.vpi install.libghdl
+install: install.$(backend) install.vhdllib install.vpi install.libghdl install.ghw
# Generate std.standard package VHDL source
$(DESTDIR)$(bindir)/ghdl$(EXEEXT) --disp-standard --std=87 > $(DESTDIR)$(VHDL_LIB_DIR)/src/std/v87/standard.vhdl
$(DESTDIR)$(bindir)/ghdl$(EXEEXT) --disp-standard --std=93 > $(DESTDIR)$(VHDL_LIB_DIR)/src/std/v93/standard.vhdl
$(DESTDIR)$(bindir)/ghdl$(EXEEXT) --disp-standard --std=08 > $(DESTDIR)$(VHDL_LIB_DIR)/src/std/v08/standard.vhdl
-uninstall: uninstall.$(backend) uninstall.vhdllib uninstall.vpi uninstall.libghdl
+uninstall: uninstall.$(backend) uninstall.vhdllib uninstall.vpi uninstall.libghdl uninstall.ghw
test: test.$(backend)
@@ -284,7 +284,7 @@ GHDL1_GCC_BIN= # --GHDL1=/path/to/ghdl1
libs.vhdl.gcc:
$(MAKE) -f $(srcdir)/libraries/Makefile.inc $(LIBVHDL_FLAGS_TO_PASS) GHDL="$(GHDL_GCC_BIN)" GHDL_FLAGS="$(GHDL1_GCC_BIN) $(LIB_CFLAGS)" vhdl.libs.all libs.vhdl.standard
-ghdllib: libs.vhdl.gcc $(libdirsuffix)/libgrt.a all.libghdl
+ghdllib: libs.vhdl.gcc $(libdirsuffix)/libgrt.a all.libghdl all.ghw
install.gcc: install.grt
@@ -474,7 +474,9 @@ libghdl-py.tgz:
GHWDUMP_OBJS=ghwdump.o ghwlib.o
-ghwdump: $(GHWDUMP_OBJS)
+ghwdump: ghwdump$(EXEEXT)
+
+ghwdump$(EXEEXT): $(GHWDUMP_OBJS)
$(CC) -o $@ $(GHWDUMP_OBJS)
ghwdump.o: $(srcdir)/src/grt/ghwdump.c $(srcdir)/src/grt/ghwlib.h
@@ -483,6 +485,14 @@ ghwdump.o: $(srcdir)/src/grt/ghwdump.c $(srcdir)/src/grt/ghwlib.h
ghwlib.o: $(srcdir)/src/grt/ghwlib.c $(srcdir)/src/grt/ghwlib.h
$(CC) -c -o $@ $< $(OPT_FLAGS) $(WARN_CFLAGS)
+all.ghw: ghwdump$(EXEEXT)
+
+install.ghw:
+ $(INSTALL_PROGRAM) -p ghwdump$(EXEEXT) $(DESTDIR)$(bindir)/
+
+uninstall.ghw:
+ $(RM) $(DESTDIR)$(bindir)/ghwdump$(EXEEXT)
+
############### grt #####################################################
install.grt: \