aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.in
diff options
context:
space:
mode:
authorXiretza <xiretza@xiretza.xyz>2022-03-17 10:12:23 +0100
committerXiretza <xiretza@xiretza.xyz>2022-03-17 10:12:23 +0100
commite7d08f71485eeeb4d0f2fcf86a4f6f78a995498d (patch)
tree3542f6539b42969d265fc18287dd8699b227ebdd /Makefile.in
parent987c5b78ab65c897d9e5757abc807df0fe264144 (diff)
downloadghdl-e7d08f71485eeeb4d0f2fcf86a4f6f78a995498d.tar.gz
ghdl-e7d08f71485eeeb4d0f2fcf86a4f6f78a995498d.tar.bz2
ghdl-e7d08f71485eeeb4d0f2fcf86a4f6f78a995498d.zip
Makefile: install.libghdl.local: don't install to DESTDIR
The purpose of the .local install targets is to install the files in-tree to allow running the test suite before installing ghdl proper.
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.in b/Makefile.in
index 12657beae..1342b02a0 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -472,8 +472,8 @@ install.libghdl.include: install.dirs $(srcdir)/src/synth/include/synth_gates.h
test: install.libghdl.local
install.libghdl.local: all.libghdl
- $(INSTALL_DATA) -p $(srcdir)/src/synth/include/synth.h $(DESTDIR)$(incdirsuffix)/ghdl
- $(INSTALL_DATA) -p $(srcdir)/src/synth/include/synth_gates.h $(DESTDIR)$(incdirsuffix)/ghdl
+ $(INSTALL_DATA) -p $(srcdir)/src/synth/include/synth.h $(incdirsuffix)/ghdl/
+ $(INSTALL_DATA) -p $(srcdir)/src/synth/include/synth_gates.h $(incdirsuffix)/ghdl/
install.libghdl.lib:
$(INSTALL_PROGRAM) -p lib/$(libghdl_name) $(DESTDIR)$(libdir)/