aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.in
diff options
context:
space:
mode:
authorTristan Gingold <tgingold@free.fr>2015-06-01 07:56:40 +0200
committerTristan Gingold <tgingold@free.fr>2015-06-01 07:56:40 +0200
commitebae3aa3d7377a314bd753d2521eed736a82cf47 (patch)
treea1ec10d3d8c4a0a599e9bb8aad483547eb34c76e /Makefile.in
parente8bd5e0824f4d3f626650446c1df438ebb7d994b (diff)
downloadghdl-ebae3aa3d7377a314bd753d2521eed736a82cf47.tar.gz
ghdl-ebae3aa3d7377a314bd753d2521eed736a82cf47.tar.bz2
ghdl-ebae3aa3d7377a314bd753d2521eed736a82cf47.zip
Add missing dependencies in Makefile.in
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.in b/Makefile.in
index 7efa305ea..9f9ea7e13 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -194,10 +194,10 @@ llvm-cbindings.o: $(srcdir)/src/ortho/llvm/llvm-cbindings.cpp
$(CXX) -c `$(LLVM_CONFIG) --includedir --cxxflags` \
$(OPT_FLAGS) -o $@ $<
-libs.vhdl.llvmjit:
+libs.vhdl.llvmjit: ghdl_llvm_jit
$(MAKE) GHDL=ghdl_llvm_jit vhdl.libs.all
-libs.vhdl.llvm:
+libs.vhdl.llvm: ghdl_llvm ghdl1-llvm
$(MAKE) GHDL=ghdl_llvm ANALYZE_OPTS="--GHDL1=ghdl1-llvm" vhdl.libs.all
$(MAKE) GHDL1=./ghdl1-llvm libs.vhdl.standard
@@ -235,7 +235,7 @@ GHDL_SIMUL_INCFLAGS=$(GHDL_COMMON_INCFLAGS) -aI$(srcdir)/src/ghdldrv -aI$(srcdir
ghdl_simul: $(GRT_ADD_OBJS) force
$(GNATMAKE) $(GHDL_SIMUL_INCFLAGS) $(GNATFLAGS) ghdl_simul $(GNAT_BARGS) -largs $(GNAT_LARGS) $(GRT_ADD_OBJS) $(subst @,$(GRTSRCDIR),$(GRT_EXTRA_LIB))
-libs.vhdl.simul:
+libs.vhdl.simul: ghdl_simul
$(MAKE) GHDL=ghdl_simul vhdl.libs.all
################ ghwdump #################################################