aboutsummaryrefslogtreecommitdiffstats
path: root/dist/msys2-mcode
diff options
context:
space:
mode:
authorUnai Martinez-Corral <38422348+umarcor@users.noreply.github.com>2020-12-31 17:58:30 +0000
committerGitHub <noreply@github.com>2020-12-31 18:58:30 +0100
commit10fe69ec4e7edca2c20aa4e49644f9cef1313a9e (patch)
treec83f2b5331d412bce13721d9d0fe9972abacbb0f /dist/msys2-mcode
parent373a991d17fd3cab3188ce23d43baae5d474f89c (diff)
downloadghdl-10fe69ec4e7edca2c20aa4e49644f9cef1313a9e.tar.gz
ghdl-10fe69ec4e7edca2c20aa4e49644f9cef1313a9e.tar.bz2
ghdl-10fe69ec4e7edca2c20aa4e49644f9cef1313a9e.zip
ci/msys2: split build and test (#1559)
Diffstat (limited to 'dist/msys2-mcode')
-rw-r--r--dist/msys2-mcode/PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/dist/msys2-mcode/PKGBUILD b/dist/msys2-mcode/PKGBUILD
index 70423d64d..11cac47c5 100644
--- a/dist/msys2-mcode/PKGBUILD
+++ b/dist/msys2-mcode/PKGBUILD
@@ -5,13 +5,18 @@ pkgver=ci
pkgrel=1
pkgdesc="GHDL: the open-source analyzer, compiler, simulator and (experimental) synthesizer for VHDL (mcode backend) (mingw-w64)"
arch=('any')
-depends=('zlib-devel')
-makedepends=("${MINGW_PACKAGE_PREFIX}-gcc" "${MINGW_PACKAGE_PREFIX}-gcc-ada")
+depends=('zlib-devel'
+ "${MINGW_PACKAGE_PREFIX}-gcc-ada")
+makedepends=("${MINGW_PACKAGE_PREFIX}-gcc")
build() {
mkdir "${srcdir}/builddir"
cd "${srcdir}/builddir"
- ../../../../configure --prefix=${MINGW_PREFIX} LDFLAGS=-static --enable-libghdl --enable-synth
+ ../../../../configure \
+ --prefix=${MINGW_PREFIX} \
+ LDFLAGS=-static \
+ --enable-libghdl \
+ --enable-synth
make GNATMAKE="gnatmake -j$(nproc)"
}