aboutsummaryrefslogtreecommitdiffstats
path: root/dist/msys2-mingw
diff options
context:
space:
mode:
authorumarcor <38422348+umarcor@users.noreply.github.com>2020-05-20 06:45:00 +0200
committerGitHub <noreply@github.com>2020-05-20 06:45:00 +0200
commit0e39a575da602ee833996c6ac30adc7c9069622e (patch)
treedb57c920a4a9b6e52958d1ebb981006ceede5684 /dist/msys2-mingw
parent42cbe9183ac8f2138ef827180baae4beaee2d3f1 (diff)
downloadghdl-0e39a575da602ee833996c6ac30adc7c9069622e.tar.gz
ghdl-0e39a575da602ee833996c6ac30adc7c9069622e.tar.bz2
ghdl-0e39a575da602ee833996c6ac30adc7c9069622e.zip
rework 'version.tmp' (#1320)
* msys2: work around makepkg hanging at the end of build() * ci: update actions/checkout to v2 * make: allow setting default description through GHDL_DESC * ci: ensure clean git describe on MSYS2
Diffstat (limited to 'dist/msys2-mingw')
-rw-r--r--dist/msys2-mingw/llvm/PKGBUILD1
-rw-r--r--dist/msys2-mingw/mcode/PKGBUILD1
-rw-r--r--dist/msys2-mingw/run.sh15
3 files changed, 13 insertions, 4 deletions
diff --git a/dist/msys2-mingw/llvm/PKGBUILD b/dist/msys2-mingw/llvm/PKGBUILD
index a947aa1e3..3fa78522d 100644
--- a/dist/msys2-mingw/llvm/PKGBUILD
+++ b/dist/msys2-mingw/llvm/PKGBUILD
@@ -19,6 +19,7 @@ build() {
cd "${srcdir}/builddir"
../../../../../configure --prefix=${MINGW_PREFIX} --with-llvm-config="llvm-config --link-static" LDFLAGS="-static" --enable-libghdl --enable-synth
make GNATMAKE="gnatmake -j$(nproc)"
+ exit
}
package() {
diff --git a/dist/msys2-mingw/mcode/PKGBUILD b/dist/msys2-mingw/mcode/PKGBUILD
index 591fa6693..79c0c399f 100644
--- a/dist/msys2-mingw/mcode/PKGBUILD
+++ b/dist/msys2-mingw/mcode/PKGBUILD
@@ -19,6 +19,7 @@ build() {
cd "${srcdir}/builddir"
../../../../../configure --prefix=${MINGW_PREFIX} LDFLAGS=-static --enable-libghdl --enable-synth
make GNATMAKE="gnatmake -j$(nproc)"
+ exit
}
package() {
diff --git a/dist/msys2-mingw/run.sh b/dist/msys2-mingw/run.sh
index a24578adc..42af9f7e5 100644
--- a/dist/msys2-mingw/run.sh
+++ b/dist/msys2-mingw/run.sh
@@ -58,7 +58,7 @@ cd $(dirname $0)
build () {
gstart 'Install common build dependencies'
- pacman -S --noconfirm base-devel git
+ pacman -S --noconfirm base-devel
gend
if [ -z "$TARGET" ]; then
@@ -67,6 +67,12 @@ build () {
fi
cd "$TARGET"
+ gstart "Fetch --unshallow"
+ # The command 'git describe' (used for version) needs the history. Get it.
+ # But the following command fails if the repository is complete.
+ git fetch --unshallow || true
+ gend
+
MINGW_INSTALLS="$(echo "$MINGW_INSTALLS" | tr '[:upper:]' '[:lower:]')"
case "$MINGW_INSTALLS" in
@@ -92,11 +98,12 @@ build () {
gend
gstart 'Build package'
- dos2unix PKGBUILD
- makepkg-mingw -sCLfc --noconfirm --noprogressbar
+ makepkg-mingw --noconfirm --noprogressbar -sCLf --noarchive
gend
- ls -la
+ gstart 'Archive package'
+ makepkg-mingw --noconfirm --noprogressbar -R
+ gend
gstart 'Install package'
pacman --noconfirm -U "mingw-w64-${TARBALL_ARCH}-ghdl-${TARGET}-ci"-*-any.pkg.tar.zst