aboutsummaryrefslogtreecommitdiffstats
path: root/dist/windows
diff options
context:
space:
mode:
authorTristan Gingold <tgingold@free.fr>2017-05-17 05:53:36 +0200
committerTristan Gingold <tgingold@free.fr>2017-05-18 07:59:34 +0200
commit513bbe9ca27c2c3beaf315df8280586a21cae76a (patch)
tree849f550b4877436e0f11ba1fc7e10ea64a05736a /dist/windows
parent8d71ed4eb2e0e4fb4081ff8f5f220fdd44a741e2 (diff)
downloadghdl-513bbe9ca27c2c3beaf315df8280586a21cae76a.tar.gz
ghdl-513bbe9ca27c2c3beaf315df8280586a21cae76a.tar.bz2
ghdl-513bbe9ca27c2c3beaf315df8280586a21cae76a.zip
Fix typo: paths.
Diffstat (limited to 'dist/windows')
-rw-r--r--dist/windows/mcode/Makefile.in22
-rw-r--r--dist/windows/mcode/default_paths.ads (renamed from dist/windows/mcode/default_pathes.ads)4
2 files changed, 13 insertions, 13 deletions
diff --git a/dist/windows/mcode/Makefile.in b/dist/windows/mcode/Makefile.in
index beb450a08..be1f11516 100644
--- a/dist/windows/mcode/Makefile.in
+++ b/dist/windows/mcode/Makefile.in
@@ -13,25 +13,25 @@ GRTSRCDIR=grt
####grt Makefile.inc
-ghdl_mcode: default_pathes.ads $(GRT_ADD_OBJS) mmap_binding.o force
+ghdl_mcode: default_paths.ads $(GRT_ADD_OBJS) mmap_binding.o force
gnatmake -aIghdldrv -aIghdl -aIortho -aIgrt $(GNATFLAGS) ghdl_mcode $(GNAT_BARGS) -largs mmap_binding.o $(GNAT_LARGS) $(GRT_ADD_OBJS) $(GRT_EXTRA_LIB) -Wl,--version-script=$(GRTSRCDIR)/grt.ver -Wl,--export-dynamic
mmap_binding.o: ortho/mmap_binding.c
$(CC) -c -g -o $@ $<
-default_pathes.ads: Makefile
- echo "-- DO NOT EDIT" > tmp-dpathes.ads
- echo "-- This file is created by Makefile" >> tmp-dpathes.ads
- echo "package Default_Pathes is" >> tmp-dpathes.ads
- echo " Prefix : constant String :=">> tmp-dpathes.ads
- echo " \"$(PREFIX)/lib/ghdl/\";" >> tmp-dpathes.ads
- echo "end Default_Pathes;" >> tmp-dpathes.ads
- if test -r $@ && cmp tmp-dpathes.ads $@; then \
+default_paths.ads: Makefile
+ echo "-- DO NOT EDIT" > tmp-dpaths.ads
+ echo "-- This file is created by Makefile" >> tmp-dpaths.ads
+ echo "package Default_Paths is" >> tmp-dpaths.ads
+ echo " Prefix : constant String :=">> tmp-dpaths.ads
+ echo " \"$(PREFIX)/lib/ghdl/\";" >> tmp-dpaths.ads
+ echo "end Default_Paths;" >> tmp-dpaths.ads
+ if test -r $@ && cmp tmp-dpaths.ads $@; then \
echo "$@ unchanged"; \
else \
- mv tmp-dpathes.ads $@; \
+ mv tmp-dpaths.ads $@; \
fi
- $(RM) tmp-dpathes.ads
+ $(RM) tmp-dpaths.ads
force:
diff --git a/dist/windows/mcode/default_pathes.ads b/dist/windows/mcode/default_paths.ads
index d83addbe2..6b1d9d952 100644
--- a/dist/windows/mcode/default_pathes.ads
+++ b/dist/windows/mcode/default_paths.ads
@@ -1,9 +1,9 @@
with Windows_Default_Path;
pragma Elaborate_All (Windows_Default_Path);
-package Default_Pathes is
+package Default_Paths is
Install_Prefix : constant String :=
Windows_Default_Path.Get_Windows_Exec_Path;
Lib_Prefix : constant String := "lib";
Shared_Library_Extension : constant String := ".dll";
-end Default_Pathes;
+end Default_Paths;