aboutsummaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author1138-4EB <1138-4EB@users.noreply.github.com>2019-09-01 10:15:34 +0200
committertgingold <tgingold@users.noreply.github.com>2019-09-01 10:15:34 +0200
commitbaeaef814b6d935906d1687c287cc66c74bf0a5c (patch)
tree53828905fd3f2b3d232adc662358500123249417 /libraries
parent84899919aee11ebec587d253c5834d7207707067 (diff)
downloadghdl-baeaef814b6d935906d1687c287cc66c74bf0a5c.tar.gz
ghdl-baeaef814b6d935906d1687c287cc66c74bf0a5c.tar.bz2
ghdl-baeaef814b6d935906d1687c287cc66c74bf0a5c.zip
Fix UPF (#905)
* add test for UPF * fix: add UPF when openieee=false too
Diffstat (limited to 'libraries')
-rw-r--r--libraries/Makefile.inc9
1 files changed, 5 insertions, 4 deletions
diff --git a/libraries/Makefile.inc b/libraries/Makefile.inc
index fbb184d74..124590733 100644
--- a/libraries/Makefile.inc
+++ b/libraries/Makefile.inc
@@ -48,6 +48,7 @@ SYNOPSYS_BSRCS := std_logic_arith.vhdl \
SYNOPSYS_V_BSRCS := std_logic_misc.vhdl std_logic_misc-body.vhdl
SYNOPSYS8793_BSRCS := std_logic_textio.vhdl
MENTOR_BSRCS := mentor/std_logic_arith.vhdl mentor/std_logic_arith-body.vhdl
+UPF_SRCS := openieee/upf.vhdl openieee/upf-body.vhdl
ifeq ($(enable_openieee),false)
IEEE_SRCS := std_logic_1164.vhdl std_logic_1164-body.vhdl \
@@ -74,16 +75,16 @@ IEEE08_BSRCS := \
ieee2008/fixed_pkg.vhdl \
ieee2008/float_generic_pkg.vhdl ieee2008/float_generic_pkg-body.vhdl \
ieee2008/float_pkg.vhdl \
- ieee2008/ieee_bit_context.vhdl ieee2008/ieee_std_context.vhdl
+ ieee2008/ieee_bit_context.vhdl ieee2008/ieee_std_context.vhdl \
+ $(UPF_SRCS)
-IEEE87_BSRCS := $(addprefix ieee/v87/,$(IEEE_SRCS))
-IEEE93_BSRCS := $(addprefix ieee/v93/,$(IEEE_SRCS)) $(addprefix ieee/,$(MATH_SRCS))
+IEEE87_BSRCS := $(addprefix ieee/v87/,$(IEEE_SRCS)) $(UPF_SRCS)
+IEEE93_BSRCS := $(addprefix ieee/v93/,$(IEEE_SRCS)) $(addprefix ieee/,$(MATH_SRCS)) $(UPF_SRCS)
else
IEEE_SRCS := std_logic_1164.vhdl std_logic_1164-body.vhdl \
numeric_bit.vhdl numeric_bit-body.vhdl \
numeric_std.vhdl numeric_std-body.vhdl
-UPF_SRCS := openieee/upf.vhdl openieee/upf-body.vhdl
MATH_SRCS := math_real.vhdl math_real-body.vhdl
VITAL95_BSRCS :=
VITAL2000_BSRCS :=