aboutsummaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
authorTristan Gingold <tgingold@free.fr>2014-09-02 21:17:16 +0200
committerTristan Gingold <tgingold@free.fr>2014-09-02 21:17:16 +0200
commite6ffb98cb5ad3f07bcaf79323d8ab8411688c494 (patch)
tree46a91868b6e4aeb5354249c74507b3e92e85f01f /libraries
parente393e8b7babd9d2dbe5e6bb7816b82036b857a1f (diff)
downloadghdl-e6ffb98cb5ad3f07bcaf79323d8ab8411688c494.tar.gz
ghdl-e6ffb98cb5ad3f07bcaf79323d8ab8411688c494.tar.bz2
ghdl-e6ffb98cb5ad3f07bcaf79323d8ab8411688c494.zip
Keep names in the tree.
This is a large change to improve error locations and allow pretty printing.
Diffstat (limited to 'libraries')
-rw-r--r--libraries/Makefile.inc5
-rw-r--r--libraries/std/textio_body.vhdl2
2 files changed, 3 insertions, 4 deletions
diff --git a/libraries/Makefile.inc b/libraries/Makefile.inc
index a6dfe61a9..92283517a 100644
--- a/libraries/Makefile.inc
+++ b/libraries/Makefile.inc
@@ -51,16 +51,15 @@ ieee2008/std_logic_1164.vhdl ieee2008/std_logic_1164-body.vhdl \
ieee2008/std_logic_textio.vhdl \
ieee2008/math_real.vhdl ieee2008/math_real-body.vhdl \
ieee2008/math_complex.vhdl ieee2008/math_complex-body.vhdl \
-ieee2008/numeric_bit.vhdl \
+ieee2008/numeric_bit.vhdl ieee2008/numeric_bit-body.vhdl \
ieee2008/numeric_bit_unsigned.vhdl ieee2008/numeric_bit_unsigned-body.vhdl \
ieee2008/numeric_std.vhdl \
ieee2008/numeric_std-body.vhdl \
ieee2008/numeric_std_unsigned.vhdl ieee2008/numeric_std_unsigned-body.vhdl \
ieee2008/fixed_float_types.vhdl \
ieee2008/fixed_generic_pkg.vhdl \
-ieee2008/fixed_pkg.vhdl \
-ieee2008/numeric_bit-body.vhdl \
ieee2008/fixed_generic_pkg-body.vhdl
+# ieee2008/fixed_pkg.vhdl \
#ieee2008/float_generic_pkg.vhdl
#ieee2008/float_generic_pkg-body.vhdl
#
diff --git a/libraries/std/textio_body.vhdl b/libraries/std/textio_body.vhdl
index b402174a4..5d148cef4 100644
--- a/libraries/std/textio_body.vhdl
+++ b/libraries/std/textio_body.vhdl
@@ -83,7 +83,7 @@ package body textio is
end case;
end is_Whitespace;
- procedure writeline (f: out text; l: inout line) is --V87
+ procedure writeline (variable f: out text; l: inout line) is --V87
procedure writeline (file f: text; l: inout line) is --V93
begin
if l = null then