aboutsummaryrefslogtreecommitdiffstats
path: root/pyGHDL/cli/dom.py
diff options
context:
space:
mode:
authorumarcor <unai.martinezcorral@ehu.eus>2021-08-23 21:20:25 +0200
committerumarcor <unai.martinezcorral@ehu.eus>2021-08-23 21:20:25 +0200
commita3255c69df60fee697e1ee546052a8abe86fb4ff (patch)
tree524c352b917e25f61f7c7b1aeec19bf831c41f7f /pyGHDL/cli/dom.py
parent8cf15b9abb3a197857627f55ef28111f9492d9d5 (diff)
downloadghdl-a3255c69df60fee697e1ee546052a8abe86fb4ff.tar.gz
ghdl-a3255c69df60fee697e1ee546052a8abe86fb4ff.tar.bz2
ghdl-a3255c69df60fee697e1ee546052a8abe86fb4ff.zip
black: rerun, to pick pyproject settings
Diffstat (limited to 'pyGHDL/cli/dom.py')
-rwxr-xr-xpyGHDL/cli/dom.py20
1 files changed, 5 insertions, 15 deletions
diff --git a/pyGHDL/cli/dom.py b/pyGHDL/cli/dom.py
index 69a0b92ec..99f59c277 100755
--- a/pyGHDL/cli/dom.py
+++ b/pyGHDL/cli/dom.py
@@ -169,13 +169,9 @@ class Application(LineTerminal, ArgParseMixin):
# Change error and warning reporting
# --------------------------------------------------------------------------
- self._LOG_MESSAGE_FORMAT__[
- Severity.Fatal
- ] = "{DARK_RED}[FATAL] {message}{NOCOLOR}"
+ self._LOG_MESSAGE_FORMAT__[Severity.Fatal] = "{DARK_RED}[FATAL] {message}{NOCOLOR}"
self._LOG_MESSAGE_FORMAT__[Severity.Error] = "{RED}[ERROR] {message}{NOCOLOR}"
- self._LOG_MESSAGE_FORMAT__[
- Severity.Warning
- ] = "{YELLOW}[WARNING] {message}{NOCOLOR}"
+ self._LOG_MESSAGE_FORMAT__[Severity.Warning] = "{YELLOW}[WARNING] {message}{NOCOLOR}"
self._LOG_MESSAGE_FORMAT__[Severity.Normal] = "{GRAY}{message}{NOCOLOR}"
# class properties
@@ -199,15 +195,9 @@ class Application(LineTerminal, ArgParseMixin):
# ============================================================================
# common arguments valid for all commands
# ----------------------------------------------------------------------------
- @CommonSwitchArgumentAttribute(
- "-d", "--debug", dest="debug", help="Enable debug mode."
- )
- @CommonSwitchArgumentAttribute(
- "-v", "--verbose", dest="verbose", help="Print out detailed messages."
- )
- @CommonSwitchArgumentAttribute(
- "-q", "--quiet", dest="quiet", help="Reduce messages to a minimum."
- )
+ @CommonSwitchArgumentAttribute("-d", "--debug", dest="debug", help="Enable debug mode.")
+ @CommonSwitchArgumentAttribute("-v", "--verbose", dest="verbose", help="Print out detailed messages.")
+ @CommonSwitchArgumentAttribute("-q", "--quiet", dest="quiet", help="Reduce messages to a minimum.")
def Run(self):
ArgParseMixin.Run(self)