aboutsummaryrefslogtreecommitdiffstats
path: root/pyGHDL/dom/NonStandard.py
diff options
context:
space:
mode:
authorPatrick Lehmann <Patrick.Lehmann@plc2.de>2021-08-23 22:04:28 +0200
committerGitHub <noreply@github.com>2021-08-23 22:04:28 +0200
commitc58dff10cb3d4d7f942ecd43169cd4681afe26f1 (patch)
tree4095a2b7e8f083ca22a9f4ca0424960002d34f9f /pyGHDL/dom/NonStandard.py
parentdac2e4dca824f413821962eeac314ceaf56925a7 (diff)
parent3dddb7dea5cf898f7f05699a7f6aee8906f9ce24 (diff)
downloadghdl-c58dff10cb3d4d7f942ecd43169cd4681afe26f1.tar.gz
ghdl-c58dff10cb3d4d7f942ecd43169cd4681afe26f1.tar.bz2
ghdl-c58dff10cb3d4d7f942ecd43169cd4681afe26f1.zip
Set black formatting to 120 chars per line.
Added pyproject.toml
Diffstat (limited to 'pyGHDL/dom/NonStandard.py')
-rw-r--r--pyGHDL/dom/NonStandard.py12
1 files changed, 3 insertions, 9 deletions
diff --git a/pyGHDL/dom/NonStandard.py b/pyGHDL/dom/NonStandard.py
index 1cd98b4fa..b0242e260 100644
--- a/pyGHDL/dom/NonStandard.py
+++ b/pyGHDL/dom/NonStandard.py
@@ -159,12 +159,8 @@ class Document(VHDLModel_Document):
bufferLength = sourceLength + 128
self.__ghdlFileID = name_table.Get_Identifier(str(self._filename))
dirId = name_table.Null_Identifier
- self.__ghdlSourceFileEntry = files_map.Reserve_Source_File(
- dirId, self.__ghdlFileID, bufferLength
- )
- files_map_editor.Fill_Text(
- self.__ghdlSourceFileEntry, ctypes.c_char_p(sourcesBytes), sourceLength
- )
+ self.__ghdlSourceFileEntry = files_map.Reserve_Source_File(dirId, self.__ghdlFileID, bufferLength)
+ files_map_editor.Fill_Text(self.__ghdlSourceFileEntry, ctypes.c_char_p(sourcesBytes), sourceLength)
CheckForErrors()
@@ -241,9 +237,7 @@ class Document(VHDLModel_Document):
self.VerificationModes.append(vmod)
else:
- raise DOMException(
- "Unknown design unit kind '{kind}'.".format(kind=nodeKind.name)
- )
+ raise DOMException("Unknown design unit kind '{kind}'.".format(kind=nodeKind.name))
@property
def LibGHDLProcessingTime(self) -> float: