aboutsummaryrefslogtreecommitdiffstats
path: root/pyGHDL/libghdl/files_map.py
diff options
context:
space:
mode:
authorPatrick Lehmann <Patrick.Lehmann@plc2.de>2021-08-23 22:04:28 +0200
committerGitHub <noreply@github.com>2021-08-23 22:04:28 +0200
commitc58dff10cb3d4d7f942ecd43169cd4681afe26f1 (patch)
tree4095a2b7e8f083ca22a9f4ca0424960002d34f9f /pyGHDL/libghdl/files_map.py
parentdac2e4dca824f413821962eeac314ceaf56925a7 (diff)
parent3dddb7dea5cf898f7f05699a7f6aee8906f9ce24 (diff)
downloadghdl-c58dff10cb3d4d7f942ecd43169cd4681afe26f1.tar.gz
ghdl-c58dff10cb3d4d7f942ecd43169cd4681afe26f1.tar.bz2
ghdl-c58dff10cb3d4d7f942ecd43169cd4681afe26f1.zip
Set black formatting to 120 chars per line.
Added pyproject.toml
Diffstat (limited to 'pyGHDL/libghdl/files_map.py')
-rw-r--r--pyGHDL/libghdl/files_map.py12
1 files changed, 3 insertions, 9 deletions
diff --git a/pyGHDL/libghdl/files_map.py b/pyGHDL/libghdl/files_map.py
index 0a288fa2e..277a00706 100644
--- a/pyGHDL/libghdl/files_map.py
+++ b/pyGHDL/libghdl/files_map.py
@@ -90,9 +90,7 @@ def Location_File_To_Line(Location: LocationType, File: SourceFileEntry) -> int:
@export
@BindToLibGHDL("files_map__location_file_line_to_offset")
-def Location_File_Line_To_Offset(
- Location: LocationType, File: SourceFileEntry, Line: int
-) -> int:
+def Location_File_Line_To_Offset(Location: LocationType, File: SourceFileEntry, Line: int) -> int:
"""
Get the offset in :obj:`Line` of :obj:`Location`.
@@ -106,9 +104,7 @@ def Location_File_Line_To_Offset(
@export
@BindToLibGHDL("files_map__location_file_line_to_col")
-def Location_File_Line_To_Col(
- Location: LocationType, File: SourceFileEntry, Line: int
-) -> int:
+def Location_File_Line_To_Col(Location: LocationType, File: SourceFileEntry, Line: int) -> int:
"""
Get logical column (with HT expanded) from :obj:`Location`, :obj:`File` and
:obj:`Line`.
@@ -259,9 +255,7 @@ def Read_Source_File(Directory: NameId, Name: NameId) -> SourceFileEntry:
@export
@BindToLibGHDL("files_map__reserve_source_file")
-def Reserve_Source_File(
- Directory: NameId, Name: NameId, Length: int
-) -> SourceFileEntry:
+def Reserve_Source_File(Directory: NameId, Name: NameId, Length: int) -> SourceFileEntry:
"""
Reserve an entry, but do not read any file.