aboutsummaryrefslogtreecommitdiffstats
path: root/pyGHDL/libghdl/libraries.py
diff options
context:
space:
mode:
authorPatrick Lehmann <Patrick.Lehmann@plc2.de>2021-08-23 22:04:28 +0200
committerGitHub <noreply@github.com>2021-08-23 22:04:28 +0200
commitc58dff10cb3d4d7f942ecd43169cd4681afe26f1 (patch)
tree4095a2b7e8f083ca22a9f4ca0424960002d34f9f /pyGHDL/libghdl/libraries.py
parentdac2e4dca824f413821962eeac314ceaf56925a7 (diff)
parent3dddb7dea5cf898f7f05699a7f6aee8906f9ce24 (diff)
downloadghdl-c58dff10cb3d4d7f942ecd43169cd4681afe26f1.tar.gz
ghdl-c58dff10cb3d4d7f942ecd43169cd4681afe26f1.tar.bz2
ghdl-c58dff10cb3d4d7f942ecd43169cd4681afe26f1.zip
Set black formatting to 120 chars per line.
Added pyproject.toml
Diffstat (limited to 'pyGHDL/libghdl/libraries.py')
-rw-r--r--pyGHDL/libghdl/libraries.py8
1 files changed, 2 insertions, 6 deletions
diff --git a/pyGHDL/libghdl/libraries.py b/pyGHDL/libghdl/libraries.py
index 07075044d..06b5f044c 100644
--- a/pyGHDL/libghdl/libraries.py
+++ b/pyGHDL/libghdl/libraries.py
@@ -54,9 +54,7 @@ A location for library declarations (such as library WORK). Use ``.value`` to
access this variable inside libghdl.
"""
-Work_Library: Iir_Library_Declaration = c_int32.in_dll(
- libghdl, "libraries__work_library"
-)
+Work_Library: Iir_Library_Declaration = c_int32.in_dll(libghdl, "libraries__work_library")
"""
Library declaration for the work library. Note: the identifier of the work_library
is ``work_library_name``, which may be different from 'WORK'. Use ``.value`` to
@@ -134,9 +132,7 @@ def Get_Library_No_Create(Ident: NameId) -> Iir_Library_Declaration:
@export
@BindToLibGHDL("libraries__find_primary_unit")
-def Find_Primary_Unit(
- Library: Iir_Library_Declaration, Name: NameId
-) -> Iir_Design_Unit:
+def Find_Primary_Unit(Library: Iir_Library_Declaration, Name: NameId) -> Iir_Design_Unit:
"""
Just return the design_unit for :obj:`Name`, or ``NULL`` if not found.