aboutsummaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorumarcor <unai.martinezcorral@ehu.eus>2021-12-15 22:46:20 +0100
committerumarcor <unai.martinezcorral@ehu.eus>2021-12-15 22:46:20 +0100
commit665761f48c3db18b62e8e1a83a0595385592d2ea (patch)
treed247c96f7125d838143eb65ddc2493b878527498 /pyproject.toml
parent918e15bb6fab7da8719624ac9d37a47db4751375 (diff)
downloadghdl-665761f48c3db18b62e8e1a83a0595385592d2ea.tar.gz
ghdl-665761f48c3db18b62e8e1a83a0595385592d2ea.tar.bz2
ghdl-665761f48c3db18b62e8e1a83a0595385592d2ea.zip
pyproject: add section 'build-system', include pyTooling.Packaging
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml8
1 files changed, 8 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 55ec8d784..3887460cc 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,2 +1,10 @@
+[build-system]
+requires = [
+ "pyTooling.Packaging >= 0.5.0",
+ "setuptools >= 35.0.2",
+ "wheel >= 0.29.0"
+]
+build-backend = "setuptools.build_meta"
+
[tool.black]
line-length = 120