aboutsummaryrefslogtreecommitdiffstats
path: root/python/libghdl/setup.py
diff options
context:
space:
mode:
author1138-4EB <1138-4EB@users.noreply.github.com>2019-06-17 03:38:27 +0200
committertgingold <tgingold@users.noreply.github.com>2019-06-17 03:38:27 +0200
commit159e0bfdbb135e74aac10e54c7a499e9e34aa5a2 (patch)
treea1ed3fbd98ddd464041a25f5e389fdd029e55528 /python/libghdl/setup.py
parentd71489efc74c55ee09f242ae5d87dbee694a8b5e (diff)
downloadghdl-159e0bfdbb135e74aac10e54c7a499e9e34aa5a2.tar.gz
ghdl-159e0bfdbb135e74aac10e54c7a499e9e34aa5a2.tar.bz2
ghdl-159e0bfdbb135e74aac10e54c7a499e9e34aa5a2.zip
Rework libghdl build/install procedure (#840)
* feat(libghdl): add libghdl_pkg.py, add option to generate libghdl-py.tgz with dist/travis/build.sh * libghdl*.so is now part of GHDL * move python sources to python/libghdl and python/pnodes * rename src/vhdl/python to src/vhdl/libghdl * add generation of tarball for libghdl-py to the makefile * deprecate --enable-python and --disable-python * add configuration option --disable-libghdl * feat(python/libghdl): add support for LIBGHDL_PREFIX (#844) * fix(travis): disable libghdl on mac * feat(python/libghdl): add support for GHDL_BIN_PATH and VUNIT_GHDL_PATH
Diffstat (limited to 'python/libghdl/setup.py')
-rw-r--r--python/libghdl/setup.py26
1 files changed, 26 insertions, 0 deletions
diff --git a/python/libghdl/setup.py b/python/libghdl/setup.py
new file mode 100644
index 000000000..c7c3de80b
--- /dev/null
+++ b/python/libghdl/setup.py
@@ -0,0 +1,26 @@
+#!/usr/bin/env python
+
+from distutils.core import setup
+from config import __version__
+
+setup(
+ name='libghdl',
+ version=__version__,
+ description='Interface to ghdl, a VHDL analyzer',
+ long_description="""GHDL is a vhdl simulator and libghdl provides a low-level
+interface to the parser. This library gives access to the AST so that you can
+write tools like linters.
+""",
+ author='Tristan Gingold',
+ author_email='tgingold@free.fr',
+ url='http://github.com/ghdl/ghdl',
+ license='GPL-2.0-or-later',
+ package_dir={
+ 'libghdl': './'
+ },
+ packages=[
+ 'libghdl',
+ 'libghdl.thin',
+ 'libghdl.thin.vhdl'
+ ]
+)