aboutsummaryrefslogtreecommitdiffstats
path: root/scripts
diff options
context:
space:
mode:
authortgingold <tgingold@users.noreply.github.com>2022-05-16 19:21:52 +0200
committerGitHub <noreply@github.com>2022-05-16 19:21:52 +0200
commit5f6eae0920bde575fc36a9661b44adbf0dfec7c7 (patch)
tree0dc5a5acf762c74e59378b783fc272b83ab3705a /scripts
parentc2475bd22f647ebea751171fc6376e0b2c872fb7 (diff)
parent9217cecc8bee7b2a6759f38eafb823703c9d0617 (diff)
downloadghdl-5f6eae0920bde575fc36a9661b44adbf0dfec7c7.tar.gz
ghdl-5f6eae0920bde575fc36a9661b44adbf0dfec7c7.tar.bz2
ghdl-5f6eae0920bde575fc36a9661b44adbf0dfec7c7.zip
Merge pull request #2058 from Xiretza/no-default-werror
fix(configure): disable -Werror by default
Diffstat (limited to 'scripts')
-rwxr-xr-xscripts/ci-run.sh2
-rw-r--r--scripts/msys2-llvm/PKGBUILD1
-rw-r--r--scripts/msys2-mcode/PKGBUILD1
3 files changed, 4 insertions, 0 deletions
diff --git a/scripts/ci-run.sh b/scripts/ci-run.sh
index 368224085..ecfd6e358 100755
--- a/scripts/ci-run.sh
+++ b/scripts/ci-run.sh
@@ -202,6 +202,8 @@ build () {
mkdir "build-$BACK"
cd "build-$BACK"
+ CONFIG_OPTS+=" --enable-werror"
+
if [ "x$ISSYNTH" = "xfalse" ]; then
CONFIG_OPTS+=" --disable-synth"
fi
diff --git a/scripts/msys2-llvm/PKGBUILD b/scripts/msys2-llvm/PKGBUILD
index 0c7848209..91aba6f59 100644
--- a/scripts/msys2-llvm/PKGBUILD
+++ b/scripts/msys2-llvm/PKGBUILD
@@ -28,6 +28,7 @@ build() {
--prefix=${MINGW_PREFIX} \
--with-llvm-config="llvm-config --link-static" \
LDFLAGS="-static" \
+ --enable-werror \
--enable-libghdl \
--enable-synth
make GNATMAKE="gnatmake -j$(nproc)"
diff --git a/scripts/msys2-mcode/PKGBUILD b/scripts/msys2-mcode/PKGBUILD
index 7c77fbf75..1e01fa613 100644
--- a/scripts/msys2-mcode/PKGBUILD
+++ b/scripts/msys2-mcode/PKGBUILD
@@ -24,6 +24,7 @@ build() {
../../../../configure \
--prefix=${MINGW_PREFIX} \
LDFLAGS="-static -Wl,--stack=8388608" \
+ --enable-werror \
--enable-libghdl \
--enable-synth
make GNATMAKE="gnatmake -j$(nproc)"