diff options
author | Patrick Lehmann <Patrick.Lehmann@plc2.de> | 2021-07-19 01:31:49 +0200 |
---|---|---|
committer | GitHub <noreply@github.com> | 2021-07-19 01:31:49 +0200 |
commit | 00667c1805c96c112c0cc4874351354d335af52f (patch) | |
tree | 9b14fbbb03e27e68aedb1f539b2f5cfb6f93018c /setup.py | |
parent | d6c71f92412036657c423572e34550b0a733c3fc (diff) | |
parent | ef4bcbb15afd7c1cde9432d192be15c184cac629 (diff) | |
download | ghdl-00667c1805c96c112c0cc4874351354d335af52f.tar.gz ghdl-00667c1805c96c112c0cc4874351354d335af52f.tar.bz2 ghdl-00667c1805c96c112c0cc4874351354d335af52f.zip |
ci: generate standalone zipfiles and add CPython jobs
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 11 |
1 files changed, 6 insertions, 5 deletions
@@ -62,16 +62,17 @@ def get_description(file: Path) -> str: def get_requirements(file: Path) -> List[str]: requirements = [] with file.open("r") as fh: - for line in fh.readlines(): - line = line.strip() + for line in fh.read().splitlines(): if line.startswith("#") or line == "": continue elif line.startswith("-r"): - filename = line[3:].strip() + # Remove the first word/argument (-r) + filename = " ".join(line.split(" ")[1:]) requirements += get_requirements(file.parent / filename) elif line.startswith("https"): - _splitItems = line.split("#") - requirements.append("{} @ {}".format(_splitItems[1], _splitItems[0])) + # Convert 'URL#NAME' to 'NAME @ URL' + splitItems = line.split("#") + requirements.append("{} @ {}".format(splitItems[1], splitItems[0])) else: requirements.append(line) return requirements |