aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorPatrick Lehmann <Patrick.Lehmann@plc2.de>2021-12-14 08:34:50 +0100
committerPatrick Lehmann <Patrick.Lehmann@plc2.de>2021-12-14 08:34:50 +0100
commit8a48be3f32e08eadc25b08d0929a9e117d8a94aa (patch)
tree94f47603b52e12ab541e8bdbe68ccef1354a48c0 /setup.py
parent595b54d85020fafebd79d83a5b931285ccd16201 (diff)
downloadghdl-8a48be3f32e08eadc25b08d0929a9e117d8a94aa.tar.gz
ghdl-8a48be3f32e08eadc25b08d0929a9e117d8a94aa.tar.bz2
ghdl-8a48be3f32e08eadc25b08d0929a9e117d8a94aa.zip
Added entry points.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 5 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index b834152ad..085d7f8e4 100644
--- a/setup.py
+++ b/setup.py
@@ -61,5 +61,9 @@ DescribePythonPackageHostedOnGitHub(
"Topic :: Software Development :: Compilers",
"Topic :: Software Development :: Testing",
"Topic :: Utilities",
- ]
+ ],
+ consoleScripts={
+ "ghdl-ls": "pyGHDL.cli.lsp:main",
+ "ghdl-dom": "pyGHDL.cli.dom:main"
+ }
)