aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorumarcor <unai.martinezcorral@ehu.eus>2021-06-23 02:54:57 +0200
committerPatrick Lehmann <Patrick.Lehmann@plc2.de>2021-06-23 11:59:19 +0200
commitd97e2079a633736d0323e915cabff5f91cfd4ebe (patch)
treea4dd72294f12438b245dd80a98fa883d06cdad48 /setup.py
parent700a2e85da31c53067b4b4139b1a0c2f78818c68 (diff)
downloadghdl-d97e2079a633736d0323e915cabff5f91cfd4ebe.tar.gz
ghdl-d97e2079a633736d0323e915cabff5f91cfd4ebe.tar.bz2
ghdl-d97e2079a633736d0323e915cabff5f91cfd4ebe.zip
setup.py: get a zipfile instead of using git
(cherry picked from commit 541815223c0df0fb2cdd227d3ca9e5a82135dc28)
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py10
1 files changed, 4 insertions, 6 deletions
diff --git a/setup.py b/setup.py
index 32acf3456..330247011 100644
--- a/setup.py
+++ b/setup.py
@@ -64,11 +64,9 @@ def get_requirements(file: Path) -> List[str]:
for line in fh.readlines():
if line.startswith("#"):
continue
- elif line.startswith("git+"):
- _splitItems = line.split("#")
- requirements.append(
- "{} @ {}".format(_splitItems[1].strip(), _splitItems[0])
- )
+ elif line.startswith("https"):
+ _splitItems = line.strip().split("#")
+ requirements.append("{} @ {}".format(_splitItems[1], _splitItems[0]))
else:
requirements.append(line.strip())
return requirements
@@ -135,7 +133,7 @@ setuptools_setup(
"Programming Language :: Python :: 3.8",
"Programming Language :: Python :: 3.9",
"Development Status :: 4 - Beta",
- # "Development Status :: 5 - Production/Stable",
+ # "Development Status :: 5 - Production/Stable",
"Intended Audience :: Developers",
"Topic :: Scientific/Engineering :: Electronic Design Automation (EDA)",
"Topic :: Software Development :: Code Generators",