aboutsummaryrefslogtreecommitdiffstats
path: root/src/grt/Makefile.inc
diff options
context:
space:
mode:
authorPatrick Lehmann <Patrick.Lehmann@tu-dresden.de>2016-06-30 14:05:18 +0200
committerPatrick Lehmann <Patrick.Lehmann@tu-dresden.de>2016-06-30 14:05:18 +0200
commit030a49838de92cb8c2bf77e025cd9ca64314b75b (patch)
tree4a20863ad14b0bf810b7c2c00333d9af4084253a /src/grt/Makefile.inc
parentecf964d43cfb36def48809fe47e43f60a5f2e4b1 (diff)
downloadghdl-030a49838de92cb8c2bf77e025cd9ca64314b75b.tar.gz
ghdl-030a49838de92cb8c2bf77e025cd9ca64314b75b.tar.bz2
ghdl-030a49838de92cb8c2bf77e025cd9ca64314b75b.zip
A first changeset for MinGW32 and MinGW64 to compile GHDL with mcode and llvm backend on Windows x86-64.
Diffstat (limited to 'src/grt/Makefile.inc')
-rw-r--r--src/grt/Makefile.inc5
1 files changed, 3 insertions, 2 deletions
diff --git a/src/grt/Makefile.inc b/src/grt/Makefile.inc
index f8a4d327a..7ac0c96d2 100644
--- a/src/grt/Makefile.inc
+++ b/src/grt/Makefile.inc
@@ -47,8 +47,9 @@ endif
GRT_ELF_OPTS:=-Wl,--version-script=@/grt.ver -Wl,--export-dynamic
# Set target files.
-ifeq ($(filter-out mingw32,$(osys)),)
- GRT_TARGET_OBJS=jumps.o math.o clock.o
+ifeq ($(filter-out mingw32 mingw64,$(osys)),)
+ GRT_TARGET_OBJS=win32.o clock.o
+ GRT_EXTRA_LIB=-ldbghelp
else
GRT_TARGET_OBJS=jumps.o times.o
ifeq ($(filter-out linux,$(osys)),)