aboutsummaryrefslogtreecommitdiffstats
path: root/src/grt/Makefile.inc
diff options
context:
space:
mode:
authorXiretza <xiretza@xiretza.xyz>2021-05-09 14:20:12 +0200
committertgingold <tgingold@users.noreply.github.com>2021-05-10 07:56:17 +0200
commit4be44d8f212ca996519389b078e0eb32d2d3ff1c (patch)
treec4cbc26f1ee44f1bc19239429a3b7e11436d7150 /src/grt/Makefile.inc
parentfe128c2b5af89d9a0a0e866fe5ecb3363cde2114 (diff)
downloadghdl-4be44d8f212ca996519389b078e0eb32d2d3ff1c.tar.gz
ghdl-4be44d8f212ca996519389b078e0eb32d2d3ff1c.tar.bz2
ghdl-4be44d8f212ca996519389b078e0eb32d2d3ff1c.zip
grt/Makefile: use CFLAGS
Diffstat (limited to 'src/grt/Makefile.inc')
-rw-r--r--src/grt/Makefile.inc4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/grt/Makefile.inc b/src/grt/Makefile.inc
index 860c91344..6e4b741e0 100644
--- a/src/grt/Makefile.inc
+++ b/src/grt/Makefile.inc
@@ -153,8 +153,8 @@ grt/run-bind.o: grt grt/run-bind.adb
grt/main.o: grt $(GRTSRCDIR)/main.adb
cd grt && $(MSYS2_ARG) $(GRT_ADACOMPILE) -o main.o $(GRTSRCDIR)/main.adb -Igrt
-GRT_C_COMPILE = $(CC) -c $(GRT_FLAGS) -o $@ $<
-GRT_C_COMPILE_PIC = $(CC) -c $(GRT_FLAGS) $(PIC_FLAGS) -o $@ $<
+GRT_C_COMPILE = $(CC) -c $(GRT_FLAGS) $(CFLAGS) -o $@ $<
+GRT_C_COMPILE_PIC = $(CC) -c $(GRT_FLAGS) $(PIC_FLAGS) $(CFLAGS) -o $@ $<
jumps.o: $(GRTSRCDIR)/config/jumps.c
$(GRT_C_COMPILE)