aboutsummaryrefslogtreecommitdiffstats
path: root/src/grt/Makefile.inc
diff options
context:
space:
mode:
authorTristan Gingold <tgingold@free.fr>2022-07-20 19:36:25 +0200
committerTristan Gingold <tgingold@free.fr>2022-07-20 19:36:25 +0200
commit76ce880bef54d80cfd5a55817b203616f50de823 (patch)
treed615ae8454d92233e38a524436bc355e8cfd68a1 /src/grt/Makefile.inc
parent158b4c6fd957b77dfcc01e7a89cca5b8bad277d8 (diff)
downloadghdl-76ce880bef54d80cfd5a55817b203616f50de823.tar.gz
ghdl-76ce880bef54d80cfd5a55817b203616f50de823.tar.bz2
ghdl-76ce880bef54d80cfd5a55817b203616f50de823.zip
configure: add --with-sundials (preliminary work)
Diffstat (limited to 'src/grt/Makefile.inc')
-rw-r--r--src/grt/Makefile.inc12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/grt/Makefile.inc b/src/grt/Makefile.inc
index 71c202e11..c8e0d9f06 100644
--- a/src/grt/Makefile.inc
+++ b/src/grt/Makefile.inc
@@ -110,6 +110,12 @@ ifeq ($(GRT_USE_PTHREADS),y)
GRT_EXTRA_LIB+=-lpthread
endif
+ifeq ($(with_sundials),true)
+ GRT_ADD_OBJS+=grt-sundials_c.o
+else
+ GRT_ADD_OBJS+=grt-no_sundials_c.o
+endif
+
GRT_LIBBACKTRACE=
ifneq ($(LIBBACKTRACE),)
GRT_LIBBACKTRACE=libbacktrace.a
@@ -217,6 +223,12 @@ pic/grt-cdynload.o: $(GRTSRCDIR)/grt-cdynload.c
grt-cthreads.o: $(GRTSRCDIR)/grt-cthreads.c
$(GRT_C_COMPILE)
+grt-sundials_c.o: $(GRTSRCDIR)/grt-sundials_c.c
+ $(GRT_C_COMPILE) $(sundials_incflags)
+
+grt-no_sundials_c.o: $(GRTSRCDIR)/grt-no_sundials_c.c
+ $(GRT_C_COMPILE)
+
fstapi.o: $(GRTSRCDIR)/fst/fstapi.c
$(GRT_C_COMPILE) -I$(GRTSRCDIR)/fst