aboutsummaryrefslogtreecommitdiffstats
path: root/src/grt/Makefile.inc
diff options
context:
space:
mode:
authorDaniel Gröber <dxld@darkboxed.org>2022-03-08 03:56:13 +0100
committertgingold <tgingold@users.noreply.github.com>2022-03-11 08:07:52 +0100
commit87df6ea6f5f49984884b6c5c336aad4e6b8dcdbe (patch)
treee63ac47d21490a300d597a685c3b34064dfe6b86 /src/grt/Makefile.inc
parent430d1ba5b09e4a2a20dc92156e5a1c69dd30bea0 (diff)
downloadghdl-87df6ea6f5f49984884b6c5c336aad4e6b8dcdbe.tar.gz
ghdl-87df6ea6f5f49984884b6c5c336aad4e6b8dcdbe.tar.bz2
ghdl-87df6ea6f5f49984884b6c5c336aad4e6b8dcdbe.zip
mk: Introduce configure options for inc/libdirsuffix
This patch is based on one from the Debian ghdl packaging. We use it to support coinstallability of the different ghdl backend executables. Force prepending ghdl/ to the include path really doesn't help us with that any. Note this effectively reverts 786ca17ce.
Diffstat (limited to 'src/grt/Makefile.inc')
-rw-r--r--src/grt/Makefile.inc26
1 files changed, 13 insertions, 13 deletions
diff --git a/src/grt/Makefile.inc b/src/grt/Makefile.inc
index acc4f3d80..2df32ec08 100644
--- a/src/grt/Makefile.inc
+++ b/src/grt/Makefile.inc
@@ -123,14 +123,14 @@ GRT_PRAGMA_FLAG=-gnatec$(GRTSRCDIR)/grt.adc -gnatdY
# Rule to compile an Ada file.
GRT_ADACOMPILE=$(GNATMAKE) -u -c $(GRT_FLAGS) $(GRT_PRAGMA_FLAG)
-grt-all: $(libdirsuffix)/libgrt.a \
- $(libdirsuffix)/$(GRT_LIBBACKTRACE) \
- $(libdirsuffix)/grt.lst \
- $(libdirsuffix)/grt-exec.lst \
- $(libdirsuffix)/grt-shared.lst \
- $(libdirsuffix)/grt.ver
-
-$(libdirsuffix)/libgrt.a: $(GRT_ADD_OBJS) grt/run-bind.o grt/main.o grt/grt-files
+grt-all: $(libghdldirsuffix)/libgrt.a \
+ $(libghdldirsuffix)/$(GRT_LIBBACKTRACE) \
+ $(libghdldirsuffix)/grt.lst \
+ $(libghdldirsuffix)/grt-exec.lst \
+ $(libghdldirsuffix)/grt-shared.lst \
+ $(libghdldirsuffix)/grt.ver
+
+$(libghdldirsuffix)/libgrt.a: $(GRT_ADD_OBJS) grt/run-bind.o grt/main.o grt/grt-files
$(RM) -f $@
$(AR) rcv $@ `sed -e "/^-/d" -e "s!^!grt/!" < grt/grt-files` \
$(GRT_ADD_OBJS) grt/run-bind.o grt/main.o
@@ -260,7 +260,7 @@ grt/grt-files.in: grt/grt-files
sed -e "\!^.[/\\]!d" -e "/-shared/d" -e "/-static/d" -e "/-lgnat/d" \
-e "\X-L/Xd" < $< > $@
-$(libdirsuffix)/grt.lst: grt/grt-files.in
+$(libghdldirsuffix)/grt.lst: grt/grt-files.in
echo "@/libgrt.a" > $@
for i in $(GRT_EXTRA_LIB); do echo $$i >> $@; done
ifneq ($(LIBBACKTRACE),)
@@ -268,19 +268,19 @@ ifneq ($(LIBBACKTRACE),)
endif
cat $< >> $@
-$(libdirsuffix)/grt-exec.lst:
+$(libghdldirsuffix)/grt-exec.lst:
echo "# link options for executables" > $@
for i in $(GRT_EXEC_OPTS); do echo $$i >> $@; done
-$(libdirsuffix)/grt-shared.lst:
+$(libghdldirsuffix)/grt-shared.lst:
echo "# link options for shared libraries" > $@
for i in $(GRT_SHARED_OPTS); do echo $$i >> $@; done
-$(libdirsuffix)/grt.ver: $(GRTSRCDIR)/grt.ver
+$(libghdldirsuffix)/grt.ver: $(GRTSRCDIR)/grt.ver
cp $< $@
ifneq ($(GRT_LIBBACKTRACE),)
-$(libdirsuffix)/$(GRT_LIBBACKTRACE): $(LIBBACKTRACE)
+$(libghdldirsuffix)/$(GRT_LIBBACKTRACE): $(LIBBACKTRACE)
cp $< $@
endif