aboutsummaryrefslogtreecommitdiffstats
path: root/src/ortho/debug
diff options
context:
space:
mode:
authorTristan Gingold <tgingold@free.fr>2014-11-13 04:44:53 +0100
committerTristan Gingold <tgingold@free.fr>2014-11-13 04:44:53 +0100
commit58a3cf18e00d419c312146a47986ae9fe5ff8802 (patch)
tree62e27f8fdb65f2003bf3b2dd90fe19b778856934 /src/ortho/debug
parentf7729f24183e51cd836a7ddd0a7ad72e0d1247c2 (diff)
downloadghdl-58a3cf18e00d419c312146a47986ae9fe5ff8802.tar.gz
ghdl-58a3cf18e00d419c312146a47986ae9fe5ff8802.tar.bz2
ghdl-58a3cf18e00d419c312146a47986ae9fe5ff8802.zip
Makefiles: fix overwrite of Makefile.in in gcc, add debug backend.
Diffstat (limited to 'src/ortho/debug')
-rw-r--r--src/ortho/debug/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/ortho/debug/Makefile b/src/ortho/debug/Makefile
index 0c15111ef..3e8bb5913 100644
--- a/src/ortho/debug/Makefile
+++ b/src/ortho/debug/Makefile
@@ -23,7 +23,7 @@ orthobe_srcdir=$(ortho_srcdir)/$(BE)
GNATMAKE=gnatmake
CC=gcc
CFLAGS=-g
-ALL_GNAT_FLAGS=-pipe -g -gnato -gnatwl -gnatf -gnaty3befhkmr -gnatwu
+ALL_GNAT_FLAGS=-pipe -g -gnato -gnatwaeu -gnatf -gnaty3befhkmr
GNATMAKE_FLAGS=-m $(ALL_GNAT_FLAGS) $(GNAT_FLAGS) -aI$(ortho_srcdir) -aI$(orthobe_srcdir) -aI.
#LARGS=-largs -static
SED=sed
@@ -32,7 +32,7 @@ all: $(ortho_exec)
$(ortho_exec): force $(ortho_srcdir)/$(BE)/ortho_debug.ads
- gnatmake -o $@ $(GNATMAKE_FLAGS) ortho_debug-main -bargs -E $(LARGS)
+ $(GNATMAKE) -o $@ $(GNATMAKE_FLAGS) ortho_debug-main -bargs -E $(LARGS)
clean:
$(RM) -f *.o *.ali *~ b~*.ad? ortho_nodes-main