aboutsummaryrefslogtreecommitdiffstats
path: root/src/ortho/llvm
diff options
context:
space:
mode:
authorTristan Gingold <tgingold@free.fr>2015-05-28 20:57:21 +0200
committerTristan Gingold <tgingold@free.fr>2015-05-28 20:57:21 +0200
commite0804ba4455959de401446178df553dc1e2d287a (patch)
treeec20c6afc434b7df55ad692e9fedfa580a3953c0 /src/ortho/llvm
parent108a813198c4078b14ef2d69e16a34d423fa0b35 (diff)
downloadghdl-e0804ba4455959de401446178df553dc1e2d287a.tar.gz
ghdl-e0804ba4455959de401446178df553dc1e2d287a.tar.bz2
ghdl-e0804ba4455959de401446178df553dc1e2d287a.zip
Fix llvm link on darwin (set no_compat_unwind).
Diffstat (limited to 'src/ortho/llvm')
-rw-r--r--src/ortho/llvm/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/ortho/llvm/Makefile b/src/ortho/llvm/Makefile
index fcf89d3ae..a9a9bdcf6 100644
--- a/src/ortho/llvm/Makefile
+++ b/src/ortho/llvm/Makefile
@@ -11,7 +11,7 @@ $(ortho_exec): $(ortho_srcdir)/llvm/ortho_llvm.ads force llvm-cbindings.o
gnatmake -o $@ -aI$(ortho_srcdir)/llvm -aI$(ortho_srcdir) \
$(GNAT_FLAGS) ortho_code_main -bargs -E \
-largs llvm-cbindings.o --LINK=$(CXX) \
- `$(LLVM_CONFIG) --ldflags --libs --system-libs`
+ `$(LLVM_CONFIG) --ldflags --libs --system-libs` $(LDFLAGS)
llvm-cbindings.o: $(ortho_srcdir)/llvm/llvm-cbindings.cpp
$(CXX) -c -I`$(LLVM_CONFIG) --includedir --cflags --cxxflags` -o $@ $<