aboutsummaryrefslogtreecommitdiffstats
path: root/src/vhdl/Makefile
diff options
context:
space:
mode:
authorTristan Gingold <tgingold@free.fr>2017-10-18 05:42:47 +0200
committerTristan Gingold <tgingold@free.fr>2017-10-18 05:42:47 +0200
commit8d2bc284f030ab3ade000f11520dfbf9d8995c69 (patch)
tree494ae66cf7266fe8e173a3e0a7d77b418788a89a /src/vhdl/Makefile
parent95bbe2124734f4687e37455d6efb7935a0ee97a3 (diff)
downloadghdl-8d2bc284f030ab3ade000f11520dfbf9d8995c69.tar.gz
ghdl-8d2bc284f030ab3ade000f11520dfbf9d8995c69.tar.bz2
ghdl-8d2bc284f030ab3ade000f11520dfbf9d8995c69.zip
Add extended locations (elocations). Still WIP
Diffstat (limited to 'src/vhdl/Makefile')
-rw-r--r--src/vhdl/Makefile27
1 files changed, 26 insertions, 1 deletions
diff --git a/src/vhdl/Makefile b/src/vhdl/Makefile
index 62428107d..3fadbeacc 100644
--- a/src/vhdl/Makefile
+++ b/src/vhdl/Makefile
@@ -26,8 +26,13 @@ PNODESPY=python/pnodespy.py
DEPS=iirs.ads nodes.ads $(PNODES)
GEN_FILES=iirs.adb nodes_meta.ads nodes_meta.adb \
+ elocations.adb elocations_meta.ads elocations_meta.adb \
python/libghdl/iirs.py python/libghdl/nodes_meta.py \
- python/libghdl/std_names.py python/libghdl/tokens.py
+ python/libghdl/std_names.py python/libghdl/tokens.py \
+ python/libghdl/elocations.py
+
+ELOCATIONS_FLAGS=--node-file=elocations.ads --field-file=elocations.adb.in \
+ --template-file=elocations.adb.in --meta-basename=elocations_meta
all: $(GEN_FILES)
@@ -46,6 +51,21 @@ nodes_meta.adb: nodes_meta.adb.in $(DEPS)
$(PNODES) meta_body > $@
chmod -w $@
+elocations.adb: elocations.adb.in elocations.ads $(DEPS)
+ $(RM) $@
+ $(PNODES) $(ELOCATIONS_FLAGS) body > $@
+ chmod -w $@
+
+elocations_meta.ads: elocations_meta.ads.in elocations.ads $(DEPS)
+ $(RM) $@
+ $(PNODES) $(ELOCATIONS_FLAGS) meta_specs > $@
+ chmod -w $@
+
+elocations_meta.adb: elocations_meta.adb.in elocations.ads $(DEPS)
+ $(RM) $@
+ $(PNODES) $(ELOCATIONS_FLAGS) meta_body > $@
+ chmod -w $@
+
python/libghdl/iirs.py: $(DEPS) $(PNODESPY)
$(RM) $@
$(PNODESPY) libghdl-iirs > $@
@@ -66,5 +86,10 @@ python/libghdl/tokens.py: $(PNODESPY) tokens.ads
$(PNODESPY) libghdl-tokens > $@
chmod -w $@
+python/libghdl/elocations.py: $(PNODESPY) elocations.ads
+ $(RM) $@
+ $(PNODESPY) $(ELOCATIONS_FLAGS) libghdl-elocs > $@
+ chmod -w $@
+
clean:
$(RM) -f $(GEN_FILES)