aboutsummaryrefslogtreecommitdiffstats
path: root/src/vhdl
diff options
context:
space:
mode:
authorTristan Gingold <tgingold@free.fr>2018-09-14 03:02:10 +0200
committerTristan Gingold <tgingold@free.fr>2018-09-15 04:14:22 +0200
commit22e5cd34c564bbc838a9765f6acd22ce73a47d93 (patch)
treea6e3b9f26a8d61db3b2099ff51af1033bbc47774 /src/vhdl
parente8ffea0c97583b564770e3ace87fa9641983ef64 (diff)
downloadghdl-22e5cd34c564bbc838a9765f6acd22ce73a47d93.tar.gz
ghdl-22e5cd34c564bbc838a9765f6acd22ce73a47d93.tar.bz2
ghdl-22e5cd34c564bbc838a9765f6acd22ce73a47d93.zip
Remove -gnat05, always use GNATFLAGS.
Fix #651
Diffstat (limited to 'src/vhdl')
-rw-r--r--src/vhdl/translate/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/src/vhdl/translate/Makefile b/src/vhdl/translate/Makefile
index b331b5728..07b3511e8 100644
--- a/src/vhdl/translate/Makefile
+++ b/src/vhdl/translate/Makefile
@@ -18,19 +18,19 @@
BE=gcc
ortho_srcdir=../ortho
-GNAT_FLAGS=-aI.. -aI../psl -gnaty3befhkmr -gnata -gnatf -gnatwael -gnat05
-#GNAT_FLAGS+=-O -gnatn
+GNATFLAGS=-aI.. -aI../psl -gnaty3befhkmr -gnata -gnatf -gnatwael
+#GNATFLAGS+=-O -gnatn
LN=ln -s
compiler: force # ortho_nodes.ads ortho_$(BE)_front.ads
$(MAKE) -f $(ortho_srcdir)/$(BE)/Makefile \
- ortho_srcdir=$(ortho_srcdir) GNAT_FLAGS="$(GNAT_FLAGS)" \
+ ortho_srcdir=$(ortho_srcdir) GNATFLAGS="$(GNATFLAGS)" \
ortho_exec=ghdl1-$(BE) all
all:
[ -d lib ] || mkdir lib
$(MAKE) -f $(ortho_srcdir)/gcc/Makefile \
- ortho_srcdir=$(ortho_srcdir) GNAT_FLAGS="$(GNAT_FLAGS)" \
+ ortho_srcdir=$(ortho_srcdir) GNATFLAGS="$(GNATFLAGS)" \
ortho_exec=ghdl1-gcc all
$(MAKE) -C ghdldrv
$(MAKE) -C grt all libdir=`pwd`/lib