aboutsummaryrefslogtreecommitdiffstats
path: root/src
diff options
context:
space:
mode:
authorPatrick Lehmann <Patrick.Lehmann@tu-dresden.de>2016-07-01 17:21:48 +0200
committerPatrick Lehmann <Patrick.Lehmann@tu-dresden.de>2016-07-01 17:21:48 +0200
commit35d71db150272a243d0e07ac37ee8abcf56f270a (patch)
tree3e0a78cccc7a07391be282d7a4cd7a80ec80f146 /src
parent50d05077aee0a8ff8020d2dcf08a7145fdc74b1e (diff)
downloadghdl-35d71db150272a243d0e07ac37ee8abcf56f270a.tar.gz
ghdl-35d71db150272a243d0e07ac37ee8abcf56f270a.tar.bz2
ghdl-35d71db150272a243d0e07ac37ee8abcf56f270a.zip
More changes for the MinGW32/MinGW64 build flow and for the llvm back-end.
Diffstat (limited to 'src')
-rw-r--r--src/ghdldrv/ghdllocal.adb2
-rw-r--r--src/grt/Makefile.inc2
-rw-r--r--src/ortho/mcode/ortho_code-x86-flags_windows64.ads2
3 files changed, 3 insertions, 3 deletions
diff --git a/src/ghdldrv/ghdllocal.adb b/src/ghdldrv/ghdllocal.adb
index fbffb5f1d..8468d77fd 100644
--- a/src/ghdldrv/ghdllocal.adb
+++ b/src/ghdldrv/ghdllocal.adb
@@ -572,7 +572,7 @@ package body Ghdllocal is
for I in Filename'Range loop
if Filename (I) = '.' then
Last := I - 1;
- elsif Remove_Dir and then Filename (I) = Directory_Separator then
+ elsif Remove_Dir and then Is_Directory_Separator (Filename (I)) then
First := I + 1;
Last := Filename'Last;
end if;
diff --git a/src/grt/Makefile.inc b/src/grt/Makefile.inc
index 7ac0c96d2..4a8af7646 100644
--- a/src/grt/Makefile.inc
+++ b/src/grt/Makefile.inc
@@ -178,7 +178,7 @@ grt-files: run-bind.adb
# Also remove -lgnat and its associated -L flags. This appears to be required
# with GNAT GPL 2005.
grt-files.in: grt-files
- sed -e "\!^./!d" -e "/-shared/d" -e "/-static/d" -e "/-lgnat/d" \
+ sed -e "\!^.[/\\]!d" -e "/-shared/d" -e "/-static/d" -e "/-lgnat/d" \
-e "\X-L/Xd" < $< > $@
grt.lst: grt-files.in
diff --git a/src/ortho/mcode/ortho_code-x86-flags_windows64.ads b/src/ortho/mcode/ortho_code-x86-flags_windows64.ads
index 1e7550012..b2063e4d4 100644
--- a/src/ortho/mcode/ortho_code-x86-flags_windows64.ads
+++ b/src/ortho/mcode/ortho_code-x86-flags_windows64.ads
@@ -30,5 +30,5 @@ package Ortho_Code.X86.Flags_Windows64 is
Mode_F64_Align : constant Natural := 3;
-- 32 bits.
- M64 : constant Boolean := False;
+ M64 : constant Boolean := True;
end Ortho_Code.X86.Flags_Windows64;