aboutsummaryrefslogtreecommitdiffstats
path: root/testsuite/gna/issue382/Makefile
diff options
context:
space:
mode:
authorTristan Gingold <tgingold@free.fr>2017-07-14 07:48:14 +0200
committerTristan Gingold <tgingold@free.fr>2017-07-14 07:48:14 +0200
commitc14fe80a292695f6245dbea1df9202bf4b5a6c98 (patch)
tree5c81fa92f3bdcb6ffa56537cbfaf5cd1bfd4902a /testsuite/gna/issue382/Makefile
parente0ece4a694de1b31cb71f17e8d7178dab9c15893 (diff)
downloadghdl-c14fe80a292695f6245dbea1df9202bf4b5a6c98.tar.gz
ghdl-c14fe80a292695f6245dbea1df9202bf4b5a6c98.tar.bz2
ghdl-c14fe80a292695f6245dbea1df9202bf4b5a6c98.zip
Add testcase from #382
Diffstat (limited to 'testsuite/gna/issue382/Makefile')
-rw-r--r--testsuite/gna/issue382/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/testsuite/gna/issue382/Makefile b/testsuite/gna/issue382/Makefile
new file mode 100644
index 000000000..8e2597dd1
--- /dev/null
+++ b/testsuite/gna/issue382/Makefile
@@ -0,0 +1,24 @@
+ANALYSE=ghdl -a
+ELABORATE=ghdl -e
+VPATH=.
+
+OBJECTS= demo.o tb_demo.o
+
+all: tb_demo
+
+sim:
+ ./tb_demo --stop-time=15sec --wave=tb_demo.ghw
+gsim:
+ killall gtkwave; true
+ ./tb_demo --stop-time=300sec --wave=tb_demo.ghw
+ gtkwave tb_demo.ghw tb_demo.gtk
+
+tb_demo: $(OBJECTS)
+ $(ELABORATE) $@
+
+%.o: %.vhd
+ $(ANALYSE) $<
+
+clean:
+ $(RM) *.o tb_demo e~tb_demoe.lst *~ work-obj93.cf
+