aboutsummaryrefslogtreecommitdiffstats
path: root/translate/gcc
diff options
context:
space:
mode:
authorgingold <gingold@b72b5c32-5f01-0410-b925-b5c7b92870f7>2005-10-09 17:27:11 +0000
committergingold <gingold@b72b5c32-5f01-0410-b925-b5c7b92870f7>2005-10-09 17:27:11 +0000
commit70cc586c068c297bdd1fbb0285473246f8812655 (patch)
treec8b7d3fba77073d79d2c7f88bb29e722caf74362 /translate/gcc
parent637d7c01c8c5d577f590f0d6891ab214697255b9 (diff)
downloadghdl-70cc586c068c297bdd1fbb0285473246f8812655.tar.gz
ghdl-70cc586c068c297bdd1fbb0285473246f8812655.tar.bz2
ghdl-70cc586c068c297bdd1fbb0285473246f8812655.zip
--vcdz option added,
switched to gcc-4.0.2, can be compiled with GNAT GPL 2005 ready for ada05 (interface identifier not used anymore) bug fixes
Diffstat (limited to 'translate/gcc')
-rw-r--r--translate/gcc/Make-lang.in2
-rw-r--r--translate/gcc/Makefile.in2
-rw-r--r--translate/gcc/README2
-rw-r--r--translate/gcc/config-lang.in2
-rwxr-xr-xtranslate/gcc/dist.sh59
5 files changed, 19 insertions, 48 deletions
diff --git a/translate/gcc/Make-lang.in b/translate/gcc/Make-lang.in
index 2aa27a1e0..cb7335c49 100644
--- a/translate/gcc/Make-lang.in
+++ b/translate/gcc/Make-lang.in
@@ -68,7 +68,7 @@ agcc_objdir=.
AGCC_GCCSRC_DIR=$(srcdir)/..
AGCC_GCCOBJ_DIR=..
-####agcc Makefile.inc
+####gcc Makefile.inc
# The compiler proper.
# It is compiled into the vhdl/ subdirectory to avoid file name clashes but
diff --git a/translate/gcc/Makefile.in b/translate/gcc/Makefile.in
index f459e6a09..2757b907c 100644
--- a/translate/gcc/Makefile.in
+++ b/translate/gcc/Makefile.in
@@ -176,7 +176,7 @@ drvdir/default_pathes.ads: drvdir Makefile
echo " Prefix : constant String :=">> tmp-dpathes.ads
echo " \"$(libsubdir)/vhdl/lib/\";" >> tmp-dpathes.ads
echo "end Default_Pathes;" >> tmp-dpathes.ads
- $(srcdir)/../move-if-change tmp-dpathes.ads $@
+ $(srcdir)/../../move-if-change tmp-dpathes.ads $@
../ghdl$(exeext): drvdir drvdir/default_pathes.ads force
CURDIR=`pwd`; cd $(srcdir); SRCDIR=`pwd`; cd $$CURDIR/drvdir; \
diff --git a/translate/gcc/README b/translate/gcc/README
index a3df511af..d7bab3281 100644
--- a/translate/gcc/README
+++ b/translate/gcc/README
@@ -29,7 +29,7 @@ Building GHDL from sources:
Required:
* the sources of @GCCVERSION@ (at least the core part).
Note: other versions of gcc sources have not been tested.
-* the Ada95 GNAT compiler (only GNAT v3.15p is known to work).
+* the Ada95 GNAT compiler (GNAT v3.15p and GNAT GPL 2005 are known to work).
* GNU/Linux for ix86 (pc systems) (porting is necessary for other systems)
Procedure:
diff --git a/translate/gcc/config-lang.in b/translate/gcc/config-lang.in
index 393d2277f..7010b1127 100644
--- a/translate/gcc/config-lang.in
+++ b/translate/gcc/config-lang.in
@@ -35,4 +35,4 @@ stagestuff="ghdl\$(exeext) ghdl1\$(exeext)"
outputs=vhdl/Makefile
-gtfiles="\$(srcdir)/vhdl/agcc-bindings.c"
+gtfiles="\$(srcdir)/vhdl/ortho-lang.c"
diff --git a/translate/gcc/dist.sh b/translate/gcc/dist.sh
index a946e4602..c2cd8f16f 100755
--- a/translate/gcc/dist.sh
+++ b/translate/gcc/dist.sh
@@ -38,14 +38,14 @@
set -e
-VERSION=`sed -n -e 's/.*GHDL \([0-9.]*\) (.*/\1/p' ../../version.ads`
+VERSION=`sed -n -e 's/.*GHDL \([0-9.a-z]*\) (.*/\1/p' ../../version.ads`
CWD=`pwd`
distdir=ghdl-$VERSION
tarfile=$distdir.tar
-GCCVERSION=3.4.3
+GCCVERSION=4.0.2
DISTDIR=/home/gingold/dist
GCCDIST=$DISTDIR/gcc-$GCCVERSION
GCCDISTOBJ=$GCCDIST-objs
@@ -80,7 +80,7 @@ do_Makefile ()
sed -e "/^####libraries Makefile.inc/r ../../libraries/Makefile.inc" \
-e "/^####grt Makefile.inc/r ../grt/Makefile.inc" \
< Makefile.in > $VHDLDIR/Makefile.in
- sed -e "/^####agcc Makefile.inc/r ../../ortho/agcc/Makefile.inc" \
+ sed -e "/^####gcc Makefile.inc/r ../../ortho/gcc/Makefile.inc" \
< Make-lang.in > $VHDLDIR/Make-lang.in
}
@@ -194,55 +194,22 @@ ortho_front.ads"
for i in $ortho_files; do ln -sf $CWD/../../ortho/$i $VHDLDIR/$i; done
ortho_gcc_files="
-agcc-fe.adb
lang.opt
-ortho_ident.adb
-ortho_ident.ads
-ortho_gcc_front.ads
-ortho_nodes.ads
+ortho-lang.c
ortho_gcc-main.adb
ortho_gcc-main.ads
+ortho_gcc.adb
ortho_gcc.ads
-ortho_gcc.adb"
+ortho_gcc_front.ads
+ortho_ident.adb
+ortho_ident.ads
+ortho_nodes.ads
+"
for i in $ortho_gcc_files; do
ln -sf $CWD/../../ortho/gcc/$i $VHDLDIR/$i
done
-agcc_files="
-agcc-autils.adb
-agcc-autils.ads
-agcc-convert.ads
-agcc-fe.ads
-agcc-ggc.ads
-agcc-output.ads
-agcc-rtl.ads
-agcc-stor_layout.ads
-agcc-toplev.ads
-agcc-trees.adb
-agcc-diagnostic.ads
-agcc-libiberty.ads
-agcc.ads
-agcc.adb
-c.adb
-c.ads
-agcc-hconfig.ads.in
-agcc-hwint.ads.in
-agcc-machmode.ads.in
-agcc-real.ads.in
-agcc-tm.ads.in
-agcc-trees.ads.in
-agcc-options.ads.in
-agcc-input.ads
-agcc-bindings.c
-agcc-ghdl.c
-gen_tree.c"
-
-
-for i in $agcc_files; do
- ln -sf $CWD/../../ortho/agcc/$i $VHDLDIR/$i
-done
-
ghdl_files="
ghdl_gcc.adb
ghdldrv.ads
@@ -347,12 +314,16 @@ grt-stack2.adb
grt-stack2.ads
grt-stacks.adb
grt-stacks.ads
+grt-c.ads
+grt-zlib.ads
grt-stdio.ads
grt-astdio.ads
grt-astdio.adb
grt-types.ads
grt-vcd.adb
grt-vcd.ads
+grt-vcdz.adb
+grt-vcdz.ads
grt-vital_annotate.adb
grt-vital_annotate.ads
grt-vpi.adb
@@ -497,7 +468,7 @@ do_tar_dist ()
rm -rf $bindirname
mkdir $bindirname
sed -e "s/@TARFILE@/$dir.tar/" < INSTALL > $bindirname/INSTALL
- ln COPYING $bindirname
+ ln ../../COPYING $bindirname
ln $TARINSTALL $bindirname
tar cvf $bindirname.tar $bindirname
}