aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.in b/Makefile.in
index 43381bf5f..e08e231b9 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -591,3 +591,12 @@ clean-pure-gpl:
force:
.PHONY: force clean distclean clean-c clean-pure-gpl
+
+# Most of the compilation is done through gnatmake, so using make -jX it not
+# very effective.
+# Hint: for parallel build use: make GNATMAKE="gnatmake -j8"
+# Parallel builds may fail with the llvm backend as it can start two gnatmake
+# in parallel: one for ghdl_llvm and the other for ghdl1-llvm. But they
+# share the same objects.
+# Any better fix is welcome!
+.NOTPARALLEL: