aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.in b/Makefile.in
index ac61815cf..b2d84f53a 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -300,6 +300,12 @@ libghdlsynth.a: $(GRT_ADD_OBJS) $(GRT_SRC_DEPS) version.ads force
$(RM) -f $@
ar rc $@ b~libghdlsynth.o `cat ghdlsynth.files` $(GRT_ADD_OBJS)
+install.libghdlsynth: libghdlsynth.a install.dirs
+ $(INSTALL_DATA) -p libghdlsynth.a $(DESTDIR)$(libdir)/
+ $(INSTALL_DATA) -p $(srcdir)/src/synth/ghdlsynth.h $(DESTDIR)$(incdir)/
+ $(INSTALL_DATA) -p $(srcdir)/src/synth/ghdlsynth_gates.h $(DESTDIR)$(incdir)/
+ $(INSTALL_DATA) -p ghdlsynth.link $(DESTDIR)$(libdir)/
+
################ ghwdump #################################################
GHWDUMP_OBJS=ghwdump.o ghwlib.o