aboutsummaryrefslogtreecommitdiffstats
path: root/dist/msys2-llvm/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'dist/msys2-llvm/PKGBUILD')
-rw-r--r--dist/msys2-llvm/PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/dist/msys2-llvm/PKGBUILD b/dist/msys2-llvm/PKGBUILD
index 6de6916dc..b837eed16 100644
--- a/dist/msys2-llvm/PKGBUILD
+++ b/dist/msys2-llvm/PKGBUILD
@@ -5,15 +5,21 @@ pkgver=ci
pkgrel=1
pkgdesc="GHDL: the open-source analyzer, compiler, simulator and (experimental) synthesizer for VHDL (LLVM backend) (mingw-w64)"
arch=('any')
-depends=('zlib-devel' "${MINGW_PACKAGE_PREFIX}-clang")
-makedepends=("${MINGW_PACKAGE_PREFIX}-gcc-ada")
+depends=('zlib-devel'
+ "${MINGW_PACKAGE_PREFIX}-clang"
+ "${MINGW_PACKAGE_PREFIX}-gcc-ada")
build() {
mkdir "${srcdir}/builddir"
cd "${srcdir}/builddir"
export CC=clang
export CXX=clang++
- ../../../../configure --prefix=${MINGW_PREFIX} --with-llvm-config="llvm-config --link-static" LDFLAGS="-static" --enable-libghdl --enable-synth
+ ../../../../configure \
+ --prefix=${MINGW_PREFIX} \
+ --with-llvm-config="llvm-config --link-static" \
+ LDFLAGS="-static" \
+ --enable-libghdl \
+ --enable-synth
make GNATMAKE="gnatmake -j$(nproc)"
}