aboutsummaryrefslogtreecommitdiffstats
path: root/pyGHDL/lsp/README
diff options
context:
space:
mode:
Diffstat (limited to 'pyGHDL/lsp/README')
-rw-r--r--pyGHDL/lsp/README18
1 files changed, 18 insertions, 0 deletions
diff --git a/pyGHDL/lsp/README b/pyGHDL/lsp/README
new file mode 100644
index 000000000..c82ccc4d4
--- /dev/null
+++ b/pyGHDL/lsp/README
@@ -0,0 +1,18 @@
+pyghdl is a language server for VHDL based on ghdl.
+
+It implements the Language Server Protocol.
+The server is implemented in Python (3.x) but relies on libghdl for parsing.
+
+It also provides a python interface to libghdl, which could be used to
+develop tools around the parser and analyzer.
+
+To install:
+1) First install ghdl (add --enable-python during configuration).
+ This is needed so that the libraries are available
+2) In ghdl/python, install pyghdl. There is a setup.py script, so you can do:
+ $ pip install .
+ To install for development: pip install -e .
+ Add --user to install in your home directory.
+
+The executable is named 'ghdl-ls'. It uses stdin/stdout to communicate with
+its client.