aboutsummaryrefslogtreecommitdiffstats
path: root/src/grt/Makefile.inc
diff options
context:
space:
mode:
Diffstat (limited to 'src/grt/Makefile.inc')
-rw-r--r--src/grt/Makefile.inc9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/grt/Makefile.inc b/src/grt/Makefile.inc
index 2df32ec08..71c202e11 100644
--- a/src/grt/Makefile.inc
+++ b/src/grt/Makefile.inc
@@ -61,6 +61,12 @@ ifeq ($(filter-out mingw32 mingw64 windows,$(osys)),)
GRT_EXTRA_LIB=-ldbghelp
GRT_EXEC_OPTS=
GRT_SHARED_OPTS=-Wl,-u,_ghdl_main
+
+ ifeq ($(filter-out x86_64,$(arch)),)
+ GRT_TARGET_OBJS+=chkstk-x64.o
+ else
+ GRT_TARGET_OBJS+=chkstk.o
+ endif
else
# For unix variants.
# Usually needs -dl (for dlopen) and -lm (for math functions).
@@ -232,6 +238,9 @@ pic/fastlz.o: $(GRTSRCDIR)/fst/fastlz.c
chkstk.o: $(GRTSRCDIR)/config/chkstk.S
$(GRT_C_COMPILE)
+chkstk-x64.o: $(GRTSRCDIR)/config/chkstk-x64.S
+ $(GRT_C_COMPILE)
+
grt-backtraces-impl.ads:
ifneq ($(GRT_LIBBACKTRACE),)
echo "with Grt.Backtraces.Gcc;" > $@