aboutsummaryrefslogtreecommitdiffstats
path: root/src/grt
diff options
context:
space:
mode:
Diffstat (limited to 'src/grt')
-rw-r--r--src/grt/Makefile.inc2
-rw-r--r--src/grt/config/linux.c2
2 files changed, 2 insertions, 2 deletions
diff --git a/src/grt/Makefile.inc b/src/grt/Makefile.inc
index eafa8aa9e..df368946f 100644
--- a/src/grt/Makefile.inc
+++ b/src/grt/Makefile.inc
@@ -66,7 +66,7 @@ ifeq ($(filter-out i%86 freebsd%,$(arch) $(osys)),)
GRT_EXTRA_LIB=-lm $(GRT_ELF_OPTS)
ADAC=ada
endif
-ifeq ($(filter-out x86_64 freebsd%,$(arch) $(osys)),)
+ifeq ($(filter-out x86_64 freebsd% dragonfly%,$(arch) $(osys)),)
GRT_TARGET_OBJS=amd64.o linux.o times.o
GRT_EXTRA_LIB=-lm $(GRT_ELF_OPTS)
ADAC=ada
diff --git a/src/grt/config/linux.c b/src/grt/config/linux.c
index dd2a9d8ab..43139b8db 100644
--- a/src/grt/config/linux.c
+++ b/src/grt/config/linux.c
@@ -44,7 +44,7 @@
#define EXTEND_STACK 1
#define STACK_SIGNAL SIGSEGV
#endif
-#ifdef __FreeBSD__
+#if defined (__FreeBSD__) || defined (__DragonFly__)
/* If set, SIGSEGV is caught in order to automatically grow the stacks. */
#define EXTEND_STACK 1
#define STACK_SIGNAL SIGSEGV