aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorTrammell Hudson <hudson@trmm.net>2018-07-17 07:37:12 -0400
committerTrammell Hudson <hudson@trmm.net>2018-07-17 07:40:28 -0400
commit1b1538deb49d17c55fa2ffa61c591220f7508668 (patch)
treedf26a5b2f0202abdb07f950411e25708a0969a8d /Makefile
parent5aeb5c9b4d164b39444152105b2b50a4bf10985b (diff)
downloadicestorm-1b1538deb49d17c55fa2ffa61c591220f7508668.tar.gz
icestorm-1b1538deb49d17c55fa2ffa61c591220f7508668.tar.bz2
icestorm-1b1538deb49d17c55fa2ffa61c591220f7508668.zip
Allow parallel make all to build each subdir simultaneously
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 518e08c..5a95087 100644
--- a/Makefile
+++ b/Makefile
@@ -2,7 +2,11 @@ SUBDIRS = icebox icepack iceprog icemulti icepll icetime icebram
include config.mk
-all clean install uninstall:
+all: $(addsuffix .all,$(SUBDIRS))
+$(addsuffix .all,$(SUBDIRS)):
+ $(MAKE) -C $(basename $@) all
+
+clean install uninstall:
for dir in $(SUBDIRS); do \
$(MAKE) -C $$dir $@ || exit; \
done