aboutsummaryrefslogtreecommitdiffstats
path: root/examples/hx8kboard
diff options
context:
space:
mode:
authorPiotr Esden-Tempski <piotr@esden.net>2015-12-30 12:40:20 +0100
committerPiotr Esden-Tempski <piotr@esden.net>2015-12-30 12:40:20 +0100
commit3975b0abbcde3500efd54b153d1211833c608d75 (patch)
tree49bdf9ef169ada33efc78d767b7383ec726471a6 /examples/hx8kboard
parent3ea5dbeb5c4a5ddb9969ecf067972735a5973919 (diff)
downloadicestorm-3975b0abbcde3500efd54b153d1211833c608d75.tar.gz
icestorm-3975b0abbcde3500efd54b153d1211833c608d75.tar.bz2
icestorm-3975b0abbcde3500efd54b153d1211833c608d75.zip
[examples] Added sudo prog target to prevent compiling the code as root. And made make clean more conservative.
Diffstat (limited to 'examples/hx8kboard')
-rw-r--r--examples/hx8kboard/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/examples/hx8kboard/Makefile b/examples/hx8kboard/Makefile
index bc47cf6..e9fd789 100644
--- a/examples/hx8kboard/Makefile
+++ b/examples/hx8kboard/Makefile
@@ -16,7 +16,11 @@ all: $(PROJ).bin
prog: $(PROJ).bin
iceprog $<
+sudo-prog: $(PROJ).bin
+ @echo 'Executing prog as root!!!'
+ sudo iceprog $<
+
clean:
- rm -f *.blif *.txt *.bin
+ rm -f $(PROJ).blif $(PROJ).txt $(PROJ).bin
.PHONY: all prog clean