aboutsummaryrefslogtreecommitdiffstats
path: root/examples/iceblink/Makefile
diff options
context:
space:
mode:
authorKalle Raiskila <kraiskil@iki.fi>2016-01-31 13:01:18 +0200
committerKalle Raiskila <kalle.raiskila@nokia.com>2016-01-31 13:03:11 +0200
commit438c0b55aea79da73f9be6ace4ddf2b77b749774 (patch)
treea052afe5cd645974a21463549677b329c5b8cfcc /examples/iceblink/Makefile
parentf1592d01eeb73b23d628bc802f242ac49f30d33e (diff)
downloadicestorm-438c0b55aea79da73f9be6ace4ddf2b77b749774.tar.gz
icestorm-438c0b55aea79da73f9be6ace4ddf2b77b749774.tar.bz2
icestorm-438c0b55aea79da73f9be6ace4ddf2b77b749774.zip
Port example to iceblink40 board.
Diffstat (limited to 'examples/iceblink/Makefile')
-rw-r--r--examples/iceblink/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/examples/iceblink/Makefile b/examples/iceblink/Makefile
new file mode 100644
index 0000000..8f908a8
--- /dev/null
+++ b/examples/iceblink/Makefile
@@ -0,0 +1,26 @@
+PROJ = example
+PIN_DEF = iceblink.pcf
+DEVICE = 1k
+
+all: $(PROJ).bin
+
+%.blif: %.v
+ yosys -p 'synth_ice40 -top top -blif $@' $<
+
+%.asc: $(PIN_DEF) %.blif
+ arachne-pnr -d $(DEVICE) -o $@ -p $^ -P vq100
+
+%.bin: %.asc
+ icepack $< $@
+
+prog: $(PROJ).bin
+ iCEburn.py -e -v -w $<
+
+sudo-prog: $(PROJ).bin
+ @echo 'Executing prog as root!!!'
+ iCEburn.py -e -v -w $<
+
+clean:
+ rm -f $(PROJ).blif $(PROJ).asc $(PROJ).bin
+
+.PHONY: all prog clean