aboutsummaryrefslogtreecommitdiffstats
path: root/examples/icestick
diff options
context:
space:
mode:
authorAki Van Ness <aki@lethalbit.net>2022-09-15 06:32:45 -0400
committerAki Van Ness <aki@lethalbit.net>2022-09-15 06:32:45 -0400
commitca43729f124466b816f922842353feeb3f6f8e84 (patch)
treedcb5191f0f33237ae561bfad064bd20fc397e728 /examples/icestick
parent2bc541743ada3542c6da36a50e66303b9cbd2059 (diff)
downloadicestorm-ca43729f124466b816f922842353feeb3f6f8e84.tar.gz
icestorm-ca43729f124466b816f922842353feeb3f6f8e84.tar.bz2
icestorm-ca43729f124466b816f922842353feeb3f6f8e84.zip
Replaced instances of `arachne-pnr` with the `nextpnr-ice40` equivalent
Diffstat (limited to 'examples/icestick')
-rw-r--r--examples/icestick/.gitignore31
-rw-r--r--examples/icestick/Makefile15
2 files changed, 17 insertions, 29 deletions
diff --git a/examples/icestick/.gitignore b/examples/icestick/.gitignore
index c854ccc..ac0a6a4 100644
--- a/examples/icestick/.gitignore
+++ b/examples/icestick/.gitignore
@@ -1,22 +1,9 @@
-example.bin
-example.blif
-example.asc
-example.rpt
-rs232demo.bin
-rs232demo.blif
-rs232demo.asc
-rs232demo.rpt
-rs232demo_tb
-rs232demo_tb.vcd
-rs232demo_syn.v
-rs232demo_syntb
-rs232demo_syntb.vcd
-checker.bin
-checker.blif
-checker.asc
-checker.rpt
-checker_tb
-checker_tb.vcd
-checker_syn.v
-checker_syntb
-checker_syntb.vcd
+*
+!.gitignore
+!checker_tb.v
+!checker.v
+!example.v
+!icestick.pcf
+!Makefile
+!rs232demo_tb.v
+!rs232demo.v
diff --git a/examples/icestick/Makefile b/examples/icestick/Makefile
index 58f26b9..d6a649b 100644
--- a/examples/icestick/Makefile
+++ b/examples/icestick/Makefile
@@ -4,14 +4,15 @@ PROJ = example
PIN_DEF = icestick.pcf
DEVICE = hx1k
+PACKAGE = tq144
all: $(PROJ).rpt $(PROJ).bin
-%.blif: %.v
- yosys -p 'synth_ice40 -top top -blif $@' $<
+%.json: %.v
+ yosys -p 'synth_ice40 -top top -json $@' $<
-%.asc: $(PIN_DEF) %.blif
- arachne-pnr -d $(subst hx,,$(subst lp,,$(DEVICE))) -o $@ -p $^
+%.asc: $(PIN_DEF) %.json
+ nextpnr-ice40 --$(DEVICE) --package $(PACKAGE) --asc $@ --pcf $< --json $*.json
%.bin: %.asc
icepack $< $@
@@ -25,8 +26,8 @@ all: $(PROJ).rpt $(PROJ).bin
%_tb.vcd: %_tb
vvp -N $< +vcd=$@
-%_syn.v: %.blif
- yosys -p 'read_blif -wideports $^; write_verilog $@'
+%_syn.v: %.json
+ yosys -p 'read_json $^; write_verilog $@'
%_syntb: %_tb.v %_syn.v
iverilog -o $@ $^ `yosys-config --datdir/ice40/cells_sim.v`
@@ -46,7 +47,7 @@ sudo-prog: $(PROJ).bin
sudo iceprog $<
clean:
- rm -f $(PROJ).blif $(PROJ).asc $(PROJ).rpt $(PROJ).bin
+ rm -f $(PROJ).json $(PROJ).asc $(PROJ).rpt $(PROJ).bin
.SECONDARY:
.PHONY: all prog clean