aboutsummaryrefslogtreecommitdiffstats
path: root/icebox/Makefile
diff options
context:
space:
mode:
authorAndrew Wygle <awygle@gmail.com>2018-05-12 12:59:07 -0700
committerAndrew Wygle <awygle@gmail.com>2018-05-13 11:00:26 -0700
commit6791402b08235a993c4eda23b21cae819235ab2d (patch)
tree5ffca3fa9c49ea6cc70d156f7d9a6e40b8b7657e /icebox/Makefile
parent2d571cb728247c56e248f8e94a03637b0e9737a9 (diff)
downloadicestorm-6791402b08235a993c4eda23b21cae819235ab2d.tar.gz
icestorm-6791402b08235a993c4eda23b21cae819235ab2d.tar.bz2
icestorm-6791402b08235a993c4eda23b21cae819235ab2d.zip
Add lm4k chipdb to icebox Makefile.
Diffstat (limited to 'icebox/Makefile')
-rw-r--r--icebox/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/icebox/Makefile b/icebox/Makefile
index a26d80c..5f4d47a 100644
--- a/icebox/Makefile
+++ b/icebox/Makefile
@@ -1,6 +1,6 @@
include ../config.mk
-all: chipdb-384.txt chipdb-1k.txt chipdb-8k.txt chipdb-5k.txt
+all: chipdb-384.txt chipdb-1k.txt chipdb-8k.txt chipdb-5k.txt chipdb-lm4k.txt
chipdb-384.txt: icebox.py iceboxdb.py icebox_chipdb.py
python3 icebox_chipdb.py -3 > chipdb-384.new
@@ -14,6 +14,10 @@ chipdb-5k.txt: icebox.py iceboxdb.py icebox_chipdb.py
python3 icebox_chipdb.py -5 > chipdb-5k.new
mv chipdb-5k.new chipdb-5k.txt
+chipdb-lm4k.txt: icebox.py iceboxdb.py icebox_chipdb.py
+ python3 icebox_chipdb.py -4 > chipdb-lm4k.new
+ mv chipdb-lm4k.new chipdb-lm4k.txt
+
chipdb-8k.txt: icebox.py iceboxdb.py icebox_chipdb.py
python3 icebox_chipdb.py -8 > chipdb-8k.new
mv chipdb-8k.new chipdb-8k.txt
@@ -24,7 +28,7 @@ check: all
python3 tc_logic_xpr.py
clean:
- rm -f chipdb-1k.txt chipdb-8k.txt chipdb-384.txt chipdb-5k.txt
+ rm -f chipdb-1k.txt chipdb-8k.txt chipdb-384.txt chipdb-5k.txt chipdb-lm4k.txt
rm -f icebox.pyc iceboxdb.pyc
install: all
@@ -34,6 +38,7 @@ install: all
cp chipdb-1k.txt $(DESTDIR)$(PREFIX)/share/icebox/
cp chipdb-8k.txt $(DESTDIR)$(PREFIX)/share/icebox/
cp chipdb-5k.txt $(DESTDIR)$(PREFIX)/share/icebox/
+ cp chipdb-lm4k.txt $(DESTDIR)$(PREFIX)/share/icebox/
cp icebox.py $(DESTDIR)$(PREFIX)/bin/icebox.py
cp iceboxdb.py $(DESTDIR)$(PREFIX)/bin/iceboxdb.py
cp icebox_chipdb.py $(DESTDIR)$(PREFIX)/bin/icebox_chipdb$(PY_EXE)
@@ -63,6 +68,7 @@ uninstall:
rm -f $(DESTDIR)$(PREFIX)/share/icebox/chipdb-384.txt
rm -f $(DESTDIR)$(PREFIX)/share/icebox/chipdb-1k.txt
rm -f $(DESTDIR)$(PREFIX)/share/icebox/chipdb-8k.txt
+ rm -f $(DESTDIR)$(PREFIX)/share/icebox/chipdb-lm4k.txt
-rmdir $(DESTDIR)$(PREFIX)/share/icebox
.PHONY: all check clean install uninstall