aboutsummaryrefslogtreecommitdiffstats
path: root/icefuzz/Makefile
diff options
context:
space:
mode:
authorClifford Wolf <clifford@clifford.at>2015-08-22 09:36:28 +0200
committerClifford Wolf <clifford@clifford.at>2015-08-22 09:42:57 +0200
commitf6f96a26e036e56577ad5a1bfec78fd06f419ca0 (patch)
treeb8a29bb84723e0ab31b127b89ee51cbad2948969 /icefuzz/Makefile
parentd094abca1c1c2d21b2b92dc743e2d5e767a97153 (diff)
downloadicestorm-f6f96a26e036e56577ad5a1bfec78fd06f419ca0.tar.gz
icestorm-f6f96a26e036e56577ad5a1bfec78fd06f419ca0.tar.bz2
icestorm-f6f96a26e036e56577ad5a1bfec78fd06f419ca0.zip
icefuzz: python 3
Diffstat (limited to 'icefuzz/Makefile')
-rw-r--r--icefuzz/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/icefuzz/Makefile b/icefuzz/Makefile
index 3620e10..030eb35 100644
--- a/icefuzz/Makefile
+++ b/icefuzz/Makefile
@@ -27,8 +27,8 @@ else
cp cached_ramb_8k.txt bitdata_ramb_8k.txt
cp cached_ramt_8k.txt bitdata_ramt_8k.txt
endif
- $(PYTHON) database.py
- $(PYTHON) export.py
+ python3 database.py
+ python3 export.py
diff -U0 cached_io.txt bitdata_io.txt || cp -v bitdata_io.txt cached_io.txt
diff -U0 cached_logic.txt bitdata_logic.txt || cp -v bitdata_logic.txt cached_logic.txt
diff -U0 cached_ramb.txt bitdata_ramb.txt || cp -v bitdata_ramb.txt cached_ramb.txt
@@ -63,13 +63,13 @@ datafiles: $(addprefix data_,$(addsuffix .txt,$(TESTS)))
define data_template
data_$(1).txt: make_$(1).py ../icepack/icepack
ifeq ($(EIGTHK),_8k)
- ICE8KPINS=1 $(PYTHON) make_$(1).py
+ ICE8KPINS=1 python3 make_$(1).py
ICEDEV=hx8k-ct256 $(MAKE) -C work_$(1)
- $(PYTHON) extract.py -8 work_$(1)/*.glb > $$@
+ python3 extract.py -8 work_$(1)/*.glb > $$@
else
- $(PYTHON) make_$(1).py
+ python3 make_$(1).py
$(MAKE) -C work_$(1)
- $(PYTHON) extract.py work_$(1)/*.glb > $$@
+ python3 extract.py work_$(1)/*.glb > $$@
endif
endef