aboutsummaryrefslogtreecommitdiffstats
path: root/icefuzz/make_aig.py
diff options
context:
space:
mode:
authorScott Shawcroft <scott.shawcroft@gmail.com>2017-06-22 17:38:38 -0700
committerScott Shawcroft <scott.shawcroft@gmail.com>2017-06-22 17:38:38 -0700
commit58a6110be198089d784b5ad3e2ecb611182bd5ea (patch)
tree3f15bebbc4b95584c93ad0f3412b53b7f55c8d5e /icefuzz/make_aig.py
parented8c4e8c034ffca4424f92fa683ff631c4205b50 (diff)
downloadicestorm-58a6110be198089d784b5ad3e2ecb611182bd5ea.tar.gz
icestorm-58a6110be198089d784b5ad3e2ecb611182bd5ea.tar.bz2
icestorm-58a6110be198089d784b5ad3e2ecb611182bd5ea.zip
Add icefuzz support for the UP5K and rework underlying device specification for more flexibility.
Diffstat (limited to 'icefuzz/make_aig.py')
-rw-r--r--icefuzz/make_aig.py13
1 files changed, 7 insertions, 6 deletions
diff --git a/icefuzz/make_aig.py b/icefuzz/make_aig.py
index 8dd5ef0..14431d5 100644
--- a/icefuzz/make_aig.py
+++ b/icefuzz/make_aig.py
@@ -7,11 +7,13 @@ import os
os.system("rm -rf work_aig")
os.mkdir("work_aig")
+w = len(pins) // 2
+
for idx in range(num):
with open("work_aig/aig_%02d.v" % idx, "w") as f:
- print("module top(input [31:0] a, output [31:0] y);", file=f)
+ print("module top(input [%d:0] a, output [%d:0] y);" % (w-1, w-1), file=f)
- sigs = ["a[%d]" % i for i in range(32)]
+ sigs = ["a[%d]" % i for i in range(w)]
netidx = 0
for i in range(100 if num_ramb40 < 20 else 1000):
@@ -40,20 +42,19 @@ for idx in range(num):
sigs.append(newnet)
- for i in range(32):
+ for i in range(w):
print(" assign y[%d] = %s;" % (i, sigs[i]), file=f)
print("endmodule", file=f)
with open("work_aig/aig_%02d.pcf" % idx, "w") as f:
p = np.random.permutation(pins)
- for i in range(32):
+ for i in range(w):
print("set_io a[%d] %s" % (i, p[i]), file=f)
- print("set_io y[%d] %s" % (i, p[i+32]), file=f)
+ print("set_io y[%d] %s" % (i, p[i+w]), file=f)
with open("work_aig/Makefile", "w") as f:
print("all: %s" % " ".join(["aig_%02d.bin" % i for i in range(num)]), file=f)
for i in range(num):
print("aig_%02d.bin:" % i, file=f)
print("\t-bash ../icecube.sh aig_%02d > aig_%02d.log 2>&1 && rm -rf aig_%02d.tmp || tail aig_%02d.log" % (i, i, i, i), file=f)
-