aboutsummaryrefslogtreecommitdiffstats
path: root/icefuzz/make_fanout.py
diff options
context:
space:
mode:
authorhermitsoft <hermisu@mail.com>2017-03-07 18:11:07 +0100
committerhermitsoft <hermisu@mail.com>2017-03-07 18:11:07 +0100
commit2ca9f929ac58e40c3918513bb9182ca0b929086e (patch)
tree90917e612674cce79986a2287bdf6a4facf99ded /icefuzz/make_fanout.py
parent2281f915369f2186b8a627d304ff672a73e11c7f (diff)
downloadicestorm-2ca9f929ac58e40c3918513bb9182ca0b929086e.tar.gz
icestorm-2ca9f929ac58e40c3918513bb9182ca0b929086e.tar.bz2
icestorm-2ca9f929ac58e40c3918513bb9182ca0b929086e.zip
Fixes for LP384 in some make_xx.py, etc
Diffstat (limited to 'icefuzz/make_fanout.py')
-rw-r--r--icefuzz/make_fanout.py15
1 files changed, 10 insertions, 5 deletions
diff --git a/icefuzz/make_fanout.py b/icefuzz/make_fanout.py
index 9df56c7..1102cc0 100644
--- a/icefuzz/make_fanout.py
+++ b/icefuzz/make_fanout.py
@@ -9,15 +9,20 @@ os.mkdir("work_fanout")
for idx in range(num):
with open("work_fanout/fanout_%02d.v" % idx, "w") as f:
- print("module top(input [1:0] a, output [63:0] y);", file=f)
- print(" assign y = {32{a}};", file=f)
+ if os.getenv('ICE384PINS'):
+ print("module top(input [1:0] a, output [15:0] y);", file=f)
+ print(" assign y = {8{a}};", file=f)
+ else:
+ print("module top(input [1:0] a, output [63:0] y);", file=f)
+ print(" assign y = {32{a}};", file=f)
print("endmodule", file=f)
with open("work_fanout/fanout_%02d.pcf" % idx, "w") as f:
p = np.random.permutation(pins)
- for i in range(64):
+ r = 16 if os.getenv('ICE384PINS') else 64
+ for i in range(r):
print("set_io y[%d] %s" % (i, p[i]), file=f)
- print("set_io a[0] %s" % p[64], file=f)
- print("set_io a[1] %s" % p[65], file=f)
+ print("set_io a[0] %s" % p[r], file=f)
+ print("set_io a[1] %s" % p[r+1], file=f)
with open("work_fanout/Makefile", "w") as f:
print("all: %s" % " ".join(["fanout_%02d.bin" % i for i in range(num)]), file=f)