aboutsummaryrefslogtreecommitdiffstats
path: root/icefuzz/make_logic.py
diff options
context:
space:
mode:
authorScott Shawcroft <scott.shawcroft@gmail.com>2017-07-02 15:38:44 -0700
committerScott Shawcroft <scott.shawcroft@gmail.com>2017-07-02 15:38:44 -0700
commitb00ffb1c091b65ed6c741dde74a4e7d5f709efd1 (patch)
tree37504d253d295bb2487bb5753fb22f8a8ca09d17 /icefuzz/make_logic.py
parenta25c8679ac37df5219e1d7a8cdd932288cd596b1 (diff)
downloadicestorm-b00ffb1c091b65ed6c741dde74a4e7d5f709efd1.tar.gz
icestorm-b00ffb1c091b65ed6c741dde74a4e7d5f709efd1.tar.bz2
icestorm-b00ffb1c091b65ed6c741dde74a4e7d5f709efd1.zip
Introduce device class into fuxx workign directories and have glbcheck handle unsupported 5k tiles ok.
Diffstat (limited to 'icefuzz/make_logic.py')
-rw-r--r--icefuzz/make_logic.py18
1 files changed, 9 insertions, 9 deletions
diff --git a/icefuzz/make_logic.py b/icefuzz/make_logic.py
index 7d4b62b..9a83b21 100644
--- a/icefuzz/make_logic.py
+++ b/icefuzz/make_logic.py
@@ -4,19 +4,23 @@ from fuzzconfig import *
import numpy as np
import os
-os.system("rm -rf work_logic")
-os.mkdir("work_logic")
+device_class = os.getenv("ICEDEVICE")
+
+working_dir = "work_%s_logic" % (device_class, )
+
+os.system("rm -rf " + working_dir)
+os.mkdir(working_dir)
def random_op():
return np.random.choice(["+", "-", "^", "&", "|", "&~", "|~"])
for idx in range(num):
bus_width = len(pins) // 5
- with open("work_logic/logic_%02d.v" % idx, "w") as f:
+ with open(working_dir + "/logic_%02d.v" % idx, "w") as f:
print("module top(input [%d:0] a, b, c, d, output [%d:0] y);" % (bus_width, bus_width), file=f)
print(" assign y = (a %s b) %s (c %s d);" % (random_op(), random_op(), random_op()), file=f)
print("endmodule", file=f)
- with open("work_logic/logic_%02d.pcf" % idx, "w") as f:
+ with open(working_dir + "/logic_%02d.pcf" % idx, "w") as f:
p = np.random.permutation(pins)
for i in range(bus_width):
print("set_io a[%d] %s" % (i, p[i]), file=f)
@@ -25,8 +29,4 @@ for idx in range(num):
print("set_io d[%d] %s" % (i, p[i+bus_width*3]), file=f)
print("set_io y[%d] %s" % (i, p[i+bus_width*4]), file=f)
-with open("work_logic/Makefile", "w") as f:
- print("all: %s" % " ".join(["logic_%02d.bin" % i for i in range(num)]), file=f)
- for i in range(num):
- print("logic_%02d.bin:" % i, file=f)
- print("\t-bash ../icecube.sh logic_%02d > logic_%02d.log 2>&1 && rm -rf logic_%02d.tmp || tail logic_%02d.log" % (i, i, i, i), file=f)
+output_makefile(working_dir, "logic")