aboutsummaryrefslogtreecommitdiffstats
path: root/icefuzz/make_prim.py
diff options
context:
space:
mode:
authorhermitsoft <hermisu@mail.com>2017-03-07 22:39:04 +0100
committerhermitsoft <hermisu@mail.com>2017-03-07 22:39:04 +0100
commitf8934de8d55a1461fa7081967384e692b8b935bb (patch)
tree81a7b4621b7bd9cdb921867ac169c829c15d5af2 /icefuzz/make_prim.py
parent2ca9f929ac58e40c3918513bb9182ca0b929086e (diff)
downloadicestorm-f8934de8d55a1461fa7081967384e692b8b935bb.tar.gz
icestorm-f8934de8d55a1461fa7081967384e692b8b935bb.tar.bz2
icestorm-f8934de8d55a1461fa7081967384e692b8b935bb.zip
icefuzz make_xxx.py files are ready for LP384.
Diffstat (limited to 'icefuzz/make_prim.py')
-rw-r--r--icefuzz/make_prim.py22
1 files changed, 12 insertions, 10 deletions
diff --git a/icefuzz/make_prim.py b/icefuzz/make_prim.py
index 130feec..02a6534 100644
--- a/icefuzz/make_prim.py
+++ b/icefuzz/make_prim.py
@@ -7,11 +7,13 @@ import os
os.system("rm -rf work_prim")
os.mkdir("work_prim")
+w = 5 if os.getenv('ICE384PINS') else 24
+
for idx in range(num):
with open("work_prim/prim_%02d.v" % idx, "w") as f:
clkedge = np.random.choice(["pos", "neg"])
- print("module top(input clk, input [23:0] a, b, output reg x, output reg [23:0] y);", file=f)
- print(" reg [23:0] aa, bb;", file=f)
+ print("module top(input clk, input [%s:0] a, b, output reg x, output reg [%s:0] y);""" % ( w-1, w-1 ), file=f)
+ print(" reg [%s:0] aa, bb;""" % ( w-1 ), file=f)
print(" always @(%sedge clk) aa <= a;" % clkedge, file=f)
print(" always @(%sedge clk) bb <= b;" % clkedge, file=f)
if np.random.choice([True, False]):
@@ -26,20 +28,20 @@ for idx in range(num):
with open("work_prim/prim_%02d.pcf" % idx, "w") as f:
p = np.random.permutation(pins)
if np.random.choice([True, False]):
- for i in range(24):
+ for i in range(w):
print("set_io a[%d] %s" % (i, p[i]), file=f)
if np.random.choice([True, False]):
- for i in range(24):
- print("set_io b[%d] %s" % (i, p[24+i]), file=f)
+ for i in range(w):
+ print("set_io b[%d] %s" % (i, p[w+i]), file=f)
if np.random.choice([True, False]):
- for i in range(24):
- print("set_io y[%d] %s" % (i, p[2*24+i]), file=f)
+ for i in range(w):
+ print("set_io y[%d] %s" % (i, p[2*w+i]), file=f)
if np.random.choice([True, False]):
- print("set_io x %s" % p[3*24], file=f)
+ print("set_io x %s" % p[3*w], file=f)
if np.random.choice([True, False]):
- print("set_io y %s" % p[3*24+1], file=f)
+ print("set_io y %s" % p[3*w+1], file=f)
if np.random.choice([True, False]):
- print("set_io clk %s" % p[3*24+2], file=f)
+ print("set_io clk %s" % p[3*w+2], file=f)
with open("work_prim/Makefile", "w") as f:
print("all: %s" % " ".join(["prim_%02d.bin" % i for i in range(num)]), file=f)