aboutsummaryrefslogtreecommitdiffstats
path: root/icemulti/Makefile
diff options
context:
space:
mode:
authorMarcus Comstedt <marcus@mc.pp.se>2015-08-07 19:40:34 +0200
committerMarcus Comstedt <marcus@mc.pp.se>2015-08-07 19:40:34 +0200
commitd1893e1116fee67db54962dba7417508b3128b9e (patch)
tree51276d3006349cdccbce93e39a82835a5dbc4140 /icemulti/Makefile
parentc8131e95a40064012f2f7ba4886a9fdfc79abe56 (diff)
downloadicestorm-d1893e1116fee67db54962dba7417508b3128b9e.tar.gz
icestorm-d1893e1116fee67db54962dba7417508b3128b9e.tar.bz2
icestorm-d1893e1116fee67db54962dba7417508b3128b9e.zip
Created a tool for building multiboot images
Diffstat (limited to 'icemulti/Makefile')
-rw-r--r--icemulti/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/icemulti/Makefile b/icemulti/Makefile
new file mode 100644
index 0000000..0b4e0aa
--- /dev/null
+++ b/icemulti/Makefile
@@ -0,0 +1,24 @@
+# CXX = clang
+LDLIBS = -lm -lstdc++
+CXXFLAGS = -MD -O0 -ggdb -Wall -std=c++11
+CC = $(CXX)
+DESTDIR = /usr/local
+
+all: icemulti
+
+icemulti: icemulti.o
+
+install: all
+ cp icemulti $(DESTDIR)/bin/icemulti
+
+uninstall:
+ rm -f $(DESTDIR)/bin/icemulti
+
+clean:
+ rm -f icemulti
+ rm -f *.o *.d
+
+-include *.d
+
+.PHONY: all install uninstall clean
+