aboutsummaryrefslogtreecommitdiffstats
path: root/icepll/Makefile
diff options
context:
space:
mode:
authorClifford Wolf <clifford@clifford.at>2016-02-14 13:47:27 +0100
committerClifford Wolf <clifford@clifford.at>2016-02-14 13:47:27 +0100
commita519d2ab828517fda323f6421fd98cf73603fc0e (patch)
tree920be8624bf8a5602c2491cff2e1a637bc40f3d8 /icepll/Makefile
parent04e61434577d2b167176832edd72121787f2a2db (diff)
downloadicestorm-a519d2ab828517fda323f6421fd98cf73603fc0e.tar.gz
icestorm-a519d2ab828517fda323f6421fd98cf73603fc0e.tar.bz2
icestorm-a519d2ab828517fda323f6421fd98cf73603fc0e.zip
Added/improved support for mxe-based win32 cross builds
Diffstat (limited to 'icepll/Makefile')
-rw-r--r--icepll/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/icepll/Makefile b/icepll/Makefile
index 9a190f6..b47de3e 100644
--- a/icepll/Makefile
+++ b/icepll/Makefile
@@ -2,9 +2,10 @@ include ../config.mk
LDLIBS = -lm -lstdc++
CXXFLAGS = -MD -O0 -ggdb -Wall -std=c++11 -I/usr/local/include
-all: icepll
+all: icepll$(EXE)
-icepll: icepll.o
+icepll$(EXE): icepll.o
+ $(CC) -o $@ $(LDFLAGS) $^ $(LDLIBS)
install: all
mkdir -p $(DESTDIR)$(PREFIX)/bin
@@ -14,7 +15,9 @@ uninstall:
rm -f $(DESTDIR)$(PREFIX)/bin/icepll
clean:
- rm -f icepll *.o *.d
+ rm -f icepll
+ rm -f icepll.exe
+ rm -f *.o *.d
-include *.d